VisionFive 2 refuses to boot any image other than sdcard.img

I’ve been trying to boot the debian images all day but it doesn’t work.
I’ve tried:

  • Debian 69 Image (with the appropriate firmware flashed to boot it)
  • Debian 202303 (with the latest firmware)
  • Debian 202302 (with firmware version 2.6.0)
  • Ubuntu 23 Image with the Latest Firmware

for each image I’ve waited at least 5 - 10 minutes, after that I changed the dip switch to the SD card mode, still nothing

my model its the super early bird 8GB. I’m using a Kingstom CANVAS Select Plus 32gb Class 10 as the SD Card. I don’t know what to do I’ve been trying things all day and I couldn’t get it to boot.

It would be extremely helpful to know what is output on the serial console during the boot process.
USB Serial needed?
I would also recommend Debian 202302 (with firmware version 2.6.0) at this time.
VisionFive 2 Debian Wiki - 202302 Release


VisionFive 2 Debian 202303 Image support, Please update latest u-boot-spl.bin.normal.out and visionfive2_fw_payload.img binaries by following Guide: 4.3 charpter 155 before running this 202303 Debian image. this is very important.


I’ll try that again xP

how much time does it take to boot the debian images for the first time?

one thing that I noticed is that when I flash the firmware images, and dump them, their sha256sum doesn’t match

That filesize of 3145729 (1+3145728) bytes looks wrong. If the size of the files are different the odds of the hashes/checksums matching are almost zero.
Info about VF2_v2.11.5 u-boot-spl.bin.normal.out and visionfive2_fw_payload.img are:

    File: u-boot-spl.bin.normal.out
    Size: 132208 bytes
  CRC-32: 11532862
     MD5: 1118cf69644d7565a4fc8c70de72dddb
   SHA-1: efe3acddc080878ff6ad0154c4737d6e7515d3f1
 SHA-256: a08455fe07679bda86ee2afa7aea35a84bf82f30ced085395058c3145a3ac74d
 SHA-512: bc28c37f3d15a1b60e1f340d11179b25ef84897cd6f198fb7e580653c0933a0fe12d8aa3cd99fbeed969ecd66c20a961c16e58e98cbbd7a2d948b07a71a8902c
SHA3-256: 8a3e715f417fc2aa981dc6c40b78f93d7c0ecb42e1b026a62a47b85f4530b6a4
SHA3-512: 6107cf523a7bfb6ba6b614705d1607f5fc61aa690c81c97f9d42f9a264acdc02f7f9d0c914e88c997e6413578f5cd5532e31eafb78f2141407bde1c904eab453

    File: visionfive2_fw_payload.img
    Size: 2955397 bytes
  CRC-32: 452c6590
     MD5: f294bb0fd8972718078d11a6b7321f18
   SHA-1: 5dea73d1a4c3d3a07f6d46023addcf08affbf55c
 SHA-256: 205fdfd84d37652f5653350e317409e9ab183b86abf9bd5b498000f0cd001f8a
 SHA-512: c85a298f74eb7de8293de8bbf72bcffde8b20038c95c0e693c516eb64ef9088b729ebfcec849ddf172e9c40318b83b1eabfe396fe41ab3b66890c6b0aa480954
SHA3-256: c6516364c6f821ef716b4b539d78aa627e58c3d1314af80f23930f23d0840db2
SHA3-512: 1d79b353b552b4e4094be664b3f682876745f96c537b0ecb5725da910fb21a3b911553c557ead9629caeaa794b8dc18ac13d1101b407499ae58d3e892fb6ad61
1 Like

Oh! Ok I’ll repeat the test with the provided sizes and hashes xP

1 Like

I repeated the test and the sha256sums do match, so the firmware is there. I still don’t know why is it not booting if it has the required firmware ;w;

I wonder if there’s a way to “convert” the sdcard.img into a debian image? since its the only one that boots sucessfully that could work :eyes: or inject the same bootloader that sdcard.img has into a debian image

in theory that would only require copying some files since the sdcard.img is a linux distro

With the switches in the SD position did you try to boot from Debian 202303 image ?
It was the first image to be able to boot using bootloaders from the SD card. None of the previous images could boot from the SD card they required the boot switch to be in the factory default position FLASH.

Maybe the file you download was incomplete or corrupt, did you check the filesize and checksum/hash with the one listed on the website ?

1 Like

Yes I tried that with all the images I listed on the first post xP. one difference I noticed is that the SOC gets a little bit warmer when I boot with the switches in the SD Position, but after 10 minutes it still doesn’t boot; How much time does it usually takes to boot these debian images for the first time? maybe that’s just me being inpatient xP

and also yes I checked the sha256 checksums, re-downloaded the image files 3 times before flashing to my SD Cards

1 Like

I just flashed this image (debian 202303) to my SD Card and updated my firmware to this new release, and I plugged it in; I’ll wait 1 hour this time to see if it does anything. I’ve also set the switches to the SD booting

I already checked the SDCard using a tool, and its not a fake card xP. I tested all of the 32gb of the card (the test took 1 hour xP) and it did not give me any error; and yes this SD Card is brand new, I bought it yesterday ago just for the starfive x3

(I edited this because the forum doesn’t allow me to reply anymore WHYY)

1 Like

The only other possibility I can think of is a bad (Or possibly a fake SD card, plug “fake SD card” into your search engine of choice). The the first 838881280 bytes (Or 204805 4K blocks) are fine (the filesize of VF2_v2.11.5_sdcard.img) , but somewhere after that it is corrupt.

Is it new, or a reused card ? Have you tried a different SD card ?

1 Like

Maybe it is an anti-spammer block, probably a limit on the number of posts you can create. I checked your account and it has “Joined 2 days” and 9 posts created. My guess is give it 1/6/24 hours and you will be able to post more and the limit will increase or go away over time, maybe do the tutorials might get you more posts (proves you are a human and not a bot).


That is me out of ideas. I’m sure someone else will chime in.

1 Like

You must have received mail from discobot at the beginning.
Answer him and after a few question/answer games you will have a higher status in the forum in a few minutes, which will allow you more interactions.


Did you try all combinations with the dip switches? I had first inverted them (the documentation is a confusing IMO), so the device wouldn’t boot on SD.

If you have an HDMI monitor, it should show some activity within seconds.


Please make sure you used the latest image because image-69 and image-55 does not support boot from SD card or eMMC.

1 Like