VisionFive 2 Debian Image Released

Ah, yes I should have done that. However, there are so many other options, like:


that it doesn’t really matter.

Of course I’m still waiting for actual hardware (Super Early Bird, ha!)

Hi dtometzki,

The advice would be switching to QSPI flash to boot.

Hi Selina,

great with this setting it works

1 Like

It is in the “Known Issues / Limitation” section of the PDF file:
Eth0 cannot be assigned IP address


Correct eth0 doesnt work but eth1


Hello together,

now it would be great to get the next release with Linux Kernel wifi support and HDMI Display support

I only expect it to boot from SSD and don’t care about anything else. :rofl:

1 Like

Has to correct myself. The password is starfive. But root login via ssh is not permitted. So login via user@ip
su root
and change sshd_config solve my problem :slight_smile:

I just noticed that every image has the exact same public and private ssh hosts keys. These should be unique on every machine (in theory it could allow a man-in-the-middle attack since your private host ssh key is public, but in reality most people are only a few feet/meters away from their board, so the odds of an actual MITM attack are basically zero).

But you might want to delete the following files:


$ sudo rm -i /etc/ssh/ssh_host_*
And then run the following command to create new unique ssh hosts keys known only to your machine:
$ sudo /usr/bin/ssh-keygen -A

Oh and on the client you use to ssh to the VF2 remove the old ssh hosts (public) keys
$ ssh-keygen -R insert_visionfive2_ip_address_here


If you haven’t gotten the image yet, this magnet link to the torrent should work without having to login to the google drive.


1 Like

Hello together,

now the Debian starfive image runs with wifi ESR 6600u.
My other wifi dongle doesnt work because they need additional kernel options.


1 Like

So I have the SDcard which matches both SHA sums, and the F***** thing doesn’t boot from SD card. Looking at the partition map, it’s obvious why it won’t boot. There is a note on the GitHub sdcard.img which says what is needed to boot from SD; and the bootloader for this isn’t in that configuration, so I get nothing but:

BOOT fail,Error is 0xffffffff

You literally make the board and left the note in the reference image. This feels deliberate.

Hello LewisCowles

1 Like

Pretty poor advice really though. (To be clear I’m pointing at this being inconsistency from the manufacturer).

Why for my visionfive2 it works. I can only say what i did when i had this error :frowning:
You will find boot jumpers on board. See other topic in this forum.

1 Like

I Had to change the jumpers in order to get it to boot from the SD in the first place. With the standard images (all other images I’ve tried) it boots. It’s just this debian image from the team, then needing different jumpers seems like an awful experience. If They really are using us as guinea pigs, then we should feed back to them, just how poor this experience is.

Post boot in SPI Flash mode, HDMI works, cursor works, and then the whole thing locks up. No output from SPI unfortunately, no login in GUI, keyboard input only via Putty / COM port forwarding.

I flashed the image on a sdcard with Raspberry Pi imager. Its as easy as flash RPi images. After insert the card and power the board, it boots flawlessly. Login as root, then add an user. Connect the ethernet network and install some software to test the repository (synaptic and gparted -btw it doesn’t work). I’ve tried libreoffice calc which run decently. I’m writing down this lines with firefox on the Vision Five 2.

1 Like

Can anyone else confirm if they have this?

[+0.02s] WARNING: Error getting user list from org.freedesktop.Accounts: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.fre edesktop.Accounts was not provided by any .service files
[+0.02s] DEBUG: Loading user config from /etc/lightdm/users.conf

I’m going to try a re-flash (again), but the image verified. I’ll also try another MicroSD just-in-case

Also seeing

root@starfive:/var/log/lightdm# cat seat0-greeter.log
** Message: 22:03:24.265: Starting lightdm-gtk-greeter 2.0.8 (Aug 17 2021, 15:44:22)
** Message: 22:03:24.266: [Configuration] Reading file: /usr/share/lightdm/lightdm-gtk-greeter.conf.d/01_debian.conf
** Message: 22:03:24.266: [Configuration] Reading file: /etc/lightdm/lightdm-gtk-greeter.conf
Excess arguments.
(lightdm-gtk-greeter:662): Gtk-WARNING **: 22:03:29.618: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

can you tell any more about your setup? Are you using TTL adapter, what power-supply, brand of microSD or eMMC?