VisionFive 2 Debian Image 202308 Released (latest)

VisionFive 2 Debian Image 202308 has been released. here is the simple release notes.
Please check the wiki page for more detail: VisionFive 2 Debian Wiki - 202308 Release | RVspace


  1. Although 4K resolution is supported, there is still performance drop issue where frame rate is dropped during desktop usage. Thus, it is recommended to switch to 1080p60 resolution for a smooth desktop user experience.
  2. Please avoid running apt upgrade as it will override the existing customized mesa and linux-libc-dev versions provided.
  3. This debian image contains FFmpeg, Firefox and VLC by default.
  4. Please update the SPI flash to the latest SPL/U-Boot binaries if you would like to try nvme booting (set boot mode as QSPI boot).

Image 202308 Download link:

What’s New

  • Supported SBC: VF2 v1.2A and v1.3B;
  • Based on Linux kernel 5.15 (VisionFive2 kernel tag: v3.6.1);
  • Based on StarFive U-Boot tag v3.6.1;
  • Debian snapshot date: 20221225T084846Z(sid);
  • Support V4l2 driver for wave511(decoder)
    • By default, v4l2 is blacklisted module. To load the module, refer to below steps.
      1. modprobe -r venc vdec jpu
      2. modprobe wave5
  • Adaptive CMA size changes on functionality:
    • Media playback that uses hardware codec (VPU). Includes VLC, firefox, ffplay, gstreamer, etc.
    • GPU (glmark, desktop rendering, etc.) related tasks.
  • Bluetooth:
    • Included blueman-manager package which controls bluetooth devices;
  • Support PWM lighting control for 4-lane DSI Display;
  • Bilibili h264/AVC videos is now playable (up to 1080p);
  • Firefox can now play videos with different resolution simultaneously;
  • Optimizing buffer access for zero cpoy and fix dma buffer leak;

Known Issues / Limitation

  • Desktop with 4K resolution is a bit laggy;
  • 1080p60 is playable on ffplay but with framedrops;
  • Chromium FFmpeg is not working;
  • NVME image occasionally has a slow boot time;
  • Qt modules qtwebengine failed to build;
  • NWjs Filesystem access APIs failed.;
  • NWjs mp3 encoder failed to be detected;
  • VLC media player will crash when playing video in minimized mode;

Fixed Issues

  • Wake up from Hibernation will cause display to not resume;
  • Dma buffer leak for decoder;
  • Omx can’t open multi decoder instance in one prcess;
  • VLC: EGL/wayland resize window issue;
  • VLC: window resize width/height with null value;
  • VLC: some crash issues, e.g. switching video files or opening playlist;
  • CMA issue when playing multiple videos;
  • The touch function of the MIPI screen is disabled when two screens(HDMI+MIPI) are displayed;
  • Hard decoding on MJPEG;

What’s Next

  • Debian-Installer support - Could support both SD + eMMC boot in single image;
  • Vulkan support;
  • 1080p60 video playback;

I notice that the What’s Next section is identical to the last release. Are these items being worked on? What is the status of 3D acceleration?

1 Like
  • X11 backend with Wayland still not use GPU driver (software rendering)
  • Xorg Gnome have lags with keyboard
  • glitches have been corrected but still lags on Xorg with GTK3
  • bitmaps with GTK3 have red and blue inverted
  • sdcard.img v361 do not boot on my SBC with sd, can I flash spl-uboot with an old sdcard.img ?
1 Like

Can’t you update the firmware with the current image?

1 Like

H264 video playback has improved a lot.

Can you add /sbin to PATH by default?
In the wiki, can you add sudo to the last command to install the additional packages?

sudo ./

And here is my YouTube video where I did a quick test.


sdcard.img from 361 stay on vision five 2 boot splash screen.

@bartoshe It seems you have the latest version working (202308).
Do you get proper output when you execute:

cat /proc/mtd

Because that would mean that you don’t have to use the sdcard.img, just use this image (202308).


I updated to the latest SPL/U-Boot, burned to an NVME drive, expanded to use the whole drive, ran the dependencies script and tested video.

With VLC, 1080p is still a bit slow, but I converted some videos to 720p and they work flawlessly full screen or windowed. I didn’t have any crashes during testing. I did find sound was scratchy from the jack, but excellent from HDMI.

As for the browsers, Chromium does better on most web sites, but video is still limited to 480p. Firefox seems slower then Chromium. Sound was also fine via HDMI but scratchy via jack.

The UI seems a little better - windows size and move better.

Does anyone get good sound out of the jack?

Do I need to upgrade SPL/UBoot if I have got NVMe booting in previous release?

I would read from the first post “4. Please update the SPI flash to the latest SPL/U-Boot binaries if you would like to try nvme booting (set boot mode as QSPI boot).” as you do not need to, but you probably should anyhow, upgrade the SPI flash if you do not need NVMe to boot.

Why would StarFive provide a newer version if it was not meant to be upgraded ? It is only 5 commands if you are upgrading from the previous version.

EDIT: There were 83 commits to the StarFive U-boot between v3.04 and v3.6.1, six were related to PCI and two were related to NVMe. I would see that alone as a reason to upgrade if you were using NVMe.


After following the wiki instructions and running, I am unable to install any packages.

What steps are required?

$ wget
$ chmod +x
$ sudo ./  
$ sudo apt-get install <package name>
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 gir1.2-clutter-gst-3.0 : Depends: gir1.2-clutter-1.0 (>= 1.20.0) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

@nb.o - I believe I also got this but did as suggested (ran “apt --fix-broken install”), then ran the dependencies script again and got “Install Success”.

Running apt --fix-broken install does not resolve the issue.

How to make debian (202308) see Nvme? There is no NVme0p1 in the dev/ directory, what does it depend on? I connected WD Nvme and it does not see it. Does it depend on uboot environment variables? how to set them

This is due to installation of clutter-gst-deb.tar.gz.
Also, the download link for gst-cogl.tar.gz does not exist and installation is failing.

1 Like

Is hardware decoding for h264 using wave5 kmod and mpv working under Debian?

From the mpv log it is being selected, but i get no working playback under Arch. It just stalls with a black image.

mpv -v  -hwdec=auto some.h264.file.mkv
[ffmpeg/video] h264_v4l2m2m: Using device /dev/video4
[ffmpeg/video] h264_v4l2m2m: driver 'wave5-dec' on card 'wave5-dec' in mplane mode
[ffmpeg/video] h264_v4l2m2m: requesting formats: output=H264/none capture=YU12/none
[vd] Using hardware decoding (v4l2m2m-copy).

It also triggers a kernel message

kernel: vdec 130a0000.vpu_dec: Setting read pointer for the decoder, fail: -5

The user is in the video group for /dev/video* access.

I noticed that automatic suspend is still enabled by default. It can’t even be disabled through Gnome’s settings GUI. That’s a strange choice on a device that doesn’t have a battery.

My experience was that it tries to suspend but fails due to the services being masked, still annoying since it spams the console.

I stopped it by following advice from here:

A modern alternative approach for disabling suspend and hibernation is to create /etc/systemd/sleep.conf.d/nosuspend.conf as


The above technique works on Debian 10 Buster and newer. See systemd-sleep.conf(5) for details.

1 Like

xWayland do not support GPU acceleration.

1 Like