VisionFive 2 Debian Image(December) Released

My download via your magnet link should be finished in 30 minutes, and I’ll let the machine running until the next image.

Hello, i build u-boot and opensbi and then installed the the mtd utilities via apt and the update wasnt a problem without tftp.

Are you saying that it is possible to use flashcp, even with the original SPL and U-Boot on the SBC itself?
If yes, is it possible for you to make this image available?
Or did I misunderstand your message?

Google Drive downloaded well over an hour then failed (~3 GB of >5GB).
Tried multiple times with same result.
Is there a ftp/wget site to dowload? Smaller image?

Smaller image is available in google drive inside image69 folder

Serving it now, in the US, from a GBit (fiber) uplink.

1 Like

Hello LivingLinux,

you could install on the board the apt install mtd-utils and then you can use mtd. Do you see any output from cat /proc/mtd on your board ? Perhaps you need first update your kernel.

Was able to download and unzip the smaller image files, however, the checksums son’t match.

Raspian:RasPi4:~/Downloads/RISCV >>> unzip
inflating: minimal/
inflating: minimal/
inflating: minimal/
inflating: minimal/debian-packs/
inflating: minimal/debian-packs/v8-
inflating: minimal/debian-packs/ffmpeg_gstreamer_riscv64.deb
inflating: minimal/debian-packs/nodejs-18.0.0_riscv64.deb
inflating: minimal/debian-packs/LibreOffice_7.3.4.2-2_riscv64.deb
inflating: minimal/debian-packs/firefox_105.0_riscv64.deb
inflating: minimal/debian-packs/LibreOffice_7.5_riscv64.deb
inflating: minimal/debian-packs/nwjs_0.65.1-2_riscv64.deb
inflating: minimal/debian-packs/qt-5.15-2_riscv64.deb
Raspian:RasPi4:~/Downloads/RISCV >>> unzip
inflating: minimal/starfive-jh7110-VF2_515_v2.5.0-69-minimal-desktop.img.bz2
Raspian:RasPi4:~/Downloads/RISCV >>> cd minimal
Raspian:RasPi4:~/Downloads/RISCV/minimal >>> sha256sum starfive-jh7110-VF2_515_v2.5.0-69-minimal-desktop.img.bz2
7001b60151fc57346aaa8ba1dd6285f11bbc551a77892cc490380172799dabb6 starfive-jh7110-VF2_515_v2.5.0-69-minimal-desktop.img.bz2
Raspian:RasPi4:~/Downloads/RISCV/minimal >>> ms5sum starfive-jh7110-VF2_515_v2.5.0-69-minimal-desktop.img.bz2
bash: ms5sum: command not found
Raspian:RasPi4:~/Downloads/RISCV/minimal >>> md5sum starfive-jh7110-VF2_515_v2.5.0-69-minimal-desktop.img.bz2
5d3184f990c01d102af438203ad11acd starfive-jh7110-VF2_515_v2.5.0-69-minimal-desktop.img.bz2
Raspian:RasPi4:~/Downloads/RISCV/minimal >>> cat
ffc8b1ebe171cd8eb25defe1f6b158d8 starfive-jh7110-VF2_515_v2.5.0-69-minimal-desktop.img
Raspian:RasPi4:~/Downloads/RISCV/minimal >>> cat
1a5b69dc3c362e37ec7453dcc04d1ae3e14f2fb2c772eeadb55e8b1b9609990a starfive-jh7110-VF2_515_v2.5.0-69-minimal-desktop.img
Raspian:RasPi4:~/Downloads/RISCV/minimal >>>


Ah, Ah! Sorry. Did not note that the checksums were against the uncompressed image.
AOK now!

I am looking forward to receiving a Vision5 2 board when it is ready and safe for you to ship.

Thanks for all your good work!

Raspian:RasPi4:~/Downloads/RISCV/minimal >>> md5sum starfive-jh7110-VF2_515_v2.5.0-69-minimal-desktop.img
ffc8b1ebe171cd8eb25defe1f6b158d8 starfive-jh7110-VF2_515_v2.5.0-69-minimal-desktop.img
Raspian:RasPi4:~/Downloads/RISCV/minimal >>> cat
ffc8b1ebe171cd8eb25defe1f6b158d8 starfive-jh7110-VF2_515_v2.5.0-69-minimal-desktop.img

1 Like

The root partition of the minimal image has only 1.5 GB and only 5 MB of free space.

I had to resize it - in my case to 10 GB - in order to be able to install new packages with apt get.

Suggest to make it a bit bigger.

Thank you!

1 Like

Actually no, it’s completely standard to ship a tight image. You are supposed to resize it. This keeps the distributed image small and besides, everyone will have a different size they want it resized to.

1 Like

Hmmm… resize2fs does not seem to do this. How to resize please?

root@starfive:~# /sbin/resize2fs /dev/mmcblk1p3 20G
resize2fs 1.46.5 (30-Dec-2021)
The containing partition (or device) is only 404987 (4k) blocks.
You requested a new size of 5242880 blocks.

root@starfive:~# lsblk
mtdblock0 31:0 0 128K 0 disk
mtdblock1 31:1 0 3M 0 disk
mtdblock2 31:2 0 1M 0 disk
mmcblk1 179:0 0 29.7G 0 disk
├─mmcblk1p1 179:1 0 16M 0 part
├─mmcblk1p2 179:2 0 100M 0 part /boot
└─mmcblk1p3 179:3 0 1.5G 0 part /


You need to resize the partition first. I just used fdisk /dev/mmcblk1 and deleted 3 and created it again. After that the resize2fs command works. Note, you do not need to reboot at any point.

1 Like

Works great. Thanks!!
Now to get HDMI working…

Wouldn’t it be simpler to have some firmware loader SD card image?

I don’t really want to buy a uart dongle just to install the firmware.

@tinspin If we can launch debian directly from TF card or eMMC, then users would no longer have to worry about firmware upgrades. we are still working on that, sorry for the inconvenience.

Ok, I think a step by step guide with images is needed for me to even try the flashing. I don’t want to brick the board.

  1. So what works without uart dongle? Do both 55 and 69 require it?

  2. What works without flashing at all (I read ubuntu/suse somewhere)?

  3. Do we need to use the debian release to get OpenGL ES on the GPU working?

And most important why all these steps, what caused the problems in the first place. We kinda need to understand this to build our own OSes.

I haven’t bothered to use a UART-USB dongle as for both the buildroot image and the full debian (69) you can ssh in with ssh user@$IP and do the firmware update from there. Trying to avoid the firmware update is a dead-end. (Finding the $IP depends on your setup. My router shows the DHCP assignments, but worst case you can just run nmap to find open ssh ports on your network).

So what are the instructions to do that?