VisionFive 2 Debian Image 202303 Released

VisionFive 2 Debian Image 202303 has been released. here is the simple release notes.
Please check the wiki page for more detail: VisionFive 2 Debian Wiki - 202303 Release | RVspace


  1. This release is a preview release to showcase gnome windowing system;
  2. Only a TF card image is supplied;
  3. Please switch the boot mode to SDIO mode and use the simple out-of-box setup. There is no need to upgrade the firmware.

Image Download link:

What’s New

  • Supported SBC: VF2 v1.2A and v1.3B;
  • Based on Linux kernel 5.15 (VisionFive2 kernel tag: v2.11.5);
  • Based on StarFive U-Boot tag v2.11.5;
  • Debian snapshot date: 20221225T084846Z(sid)
  • Added IPv6 support;
  • Added uboot splash screen support;
  • Added framebuffer console support;
  • 4K resolution support for X and Wayland;
  • openssh-server’ package is now re-added to the image by default and include regeneration of ssh keys;
  • Gnome Wayland Desktop for improved user experience;

Known Issues / Limitation

  • 1080p60 video playback issue;
  • libreoffice slowness using gtk3;
  • xeglinfo crashes X server;
  • Qt modules qtwebengine failed to build;
  • Firefox hardware acceleration is not working;
  • NWjs Filesystem access APIs failed;
  • NWjs mp3 encoder failed to be detected;
  • Pink screen overlay, need to use script in /opt/ and reboot, need to rerun it when using a different monitor as it ties to the monitor device ID;
  • Some resolution cannot be supported via HDMI, e.g. 2K, 1024x768…;
  • The login window does not appear when the splash screen logo is displayed on a 2-lane MIPI display;
  • The console screen is displaying a white screen probablely and then login window is not being shown;
  • Occasional kernel panic;

Fixed Issues

  • XFCE desktop resizing slowness;
  • Mosaic pictures after login;
  • Hang after awhile in dual display [MIPI+HDMI];
  • 4K monitor does not display properly;

Love the pink screen! Looks good so far.


Can’t wait for @cwt to merge this into the Arch image.

Bye Bye Raspberry Pi.

I thought something went wrong with my image.
But it looks like I’m not the only one.

1 Like

It’s explained in the release announcement

" Pink screen overlay, need to use script in /opt/ and reboot, need to rerun it when using a different monitor as it ties to the monitor device ID"


If you mean just the new u-boot, kernel, GPU firmware and its userland driver, they are already in cwt12 (just released yesterday). However, I would like to remind you that my image never intended to be use with GUI (even though some users reported that they can setup X to run on it, and I ever tried Wayland/Weston myself).

The Debian image here is a much more easy and ready-to-use for GUI users.


I’m running the latest cwt12 with all the new goodies, thank you very much. With a non-accelerated X desktop.

The Debian image is nice bling but not so useful, as the wiki states:

Note: Please avoid running apt upgrade as it will override the existing customized mesa and linux-libc-dev versions provided.、

The patched libc perhaps explaining why XWayland crashes in the Arch image.

Anyway, getting off-topic for this thread, mea culpa.


I noticed that nautilus (Gnome File Manager) can’t be installed. As an alternative I installed xfe.
I see that you shipped a script to fix the colours.
Is it an option to also ship the script in the image to install the packages like Firefox, LibreOffice, etc.?

I tried to install the Epiphany browser, but it doesn’t show anything. As an experiment I installed Lynx.
Here you can see how I installed the image and set up the applications.


I wanted to report I did repeat using the 202303 engineering image on a wiped 32GB sdcard. The sdcard booted into a very low resolution gnome desktop. It didn’t feel like 1080p. I went to displays and it stated 640x480? How can that be? I couldn’t change it either. My monitor is a Seiki 1080p muse monitor.
UPDATE: SEIKI MONITOR is ok. DON’T USE HDMI-TO-DVI ADAPTERS. You must use hdmi-only cables.

I ran that script you mentioned in your youtube video description that installs libreoffice, firefox and such.
It installed successfully.

I tried firefox with youtube, it played the video and sound was in sync.
I tried libreoffice writer and the input was working and text was displaying.

I did something to try cvt and get a higher resolution. It gave me a mode line.
I added it to xrandr and it listed it as an available mode from xrandr without any args.
When I went back to gnome → settings → displays, it only lists 640x480 as a resolution still.

Has anybody else encounter this issue with their 1080p hdmi monitor? 640x480 with gnome is unusable now.

The entire gnome desktop available yet.
The xfce desktop isn’t available yet.
I didn’t see anything demonstrating the gpu drivers being installed or opencl or anything with this image.
Did anybody have any success with respect to gpu/opencl out of the box with this image? What did you install afterwards to demonstrate it works. When should we expect an image that comes complete with all the bells and whistles that users expect? Thank you.

I use a small 1080p HDMI Samsung TV and I get the desktop in 1080p. So I’m afraid I can’t help you with that issue. But I did notice better audio quality through HDMI.

I have the feeling we still hardly use the GPU, but it claims OpenGL 3.3 support.
After installing mesa-utils, you can run glxinfo.

Firefox now is able to start WebGL Aquarium, but it is really slow. WebGL Aquarium

I compiled TyrQuake again, but this time make gave the error that it can’t find cc. So I had to use this: make CC=gcc
This time I’m able to start tyr-glquake, but that is also very slow. For now stick with tyr-quake.

I noticed that when I enter reboot, it only triggers a shutdown and the VF2 does not restart.
The reset button doesn’t help here either.


[   43.734248] systemd-shutdown[1]: All filesystems, swaps, loop devices, MD devices and DM devices detached.
[   43.746934] systemd-shutdown[1]: Syncing filesystems and block devices.
[   43.753783] systemd-shutdown[1]: Rebooting.
[   44.145599] reboot: Restarting system
1 Like

Adding Wayland into fresh 202303 image is a great step ahead. Thanks!

But I see some problems with repositories and packages. See the analysis below.
I use Debian for about 18 years, so I expect that APT is normally configured in the image and allows user to use all the contained software.

I did some testing of 202303 image written to SD card (128 Gb, Samsung EVO Plus).
White boot splash is great!
All 8 Gb of RAM were recognized on my VF2 rev v1.2a.
I use monitor with fullhd 1920x1080 resolution, I have removed pink color on first boot by running /opt/ from USB-UART console.
Then the picture looks good.

I see that /usr/local contains fewer objects out-the-box:

$ find /usr/local/ -type f

Then I have installed optional deb-packages by

sudo apt-get update

mkdir ~/Downloads
cd ~/Downloads
rm -v
sed -i "s/^wget/wget -c/g"
sed -i "s/^rm/#rm/g"
chmod +x
sudo ./

sudo apt-get install -f
sudo apt-get install aptitude

There are some crashes in the UART-console:

[  412.426920] gsd-usb-protect[1706]: unhandled signal 11 code 0x1 at 0x0000000000000008 in gsd-usb-protection[2ae76a4000+7000]
[  412.438254] CPU: 3 PID: 1706 Comm: gsd-usb-protect Tainted: G           O      5.15.0-starfive #1
[  412.447196] Hardware name: StarFive VisionFive V2 (DT)
[  412.452358] epc : 0000002ae76a82c6 ra : 0000002ae76a8252 sp : 0000003fcd0f5330
[  412.459692]  gp : 0000002ae76ac800 tp : 0000003fa9d75de0 t0 : 0000000000000000
[  412.466972]  t1 : 0000002ae76a681c t2 : ce74ecdcb57f7893 s0 : 0000002ae76c1000
[  412.474211]  s1 : 0000000000000000 a0 : 0000000000000000 a1 : 0000000000000010
[  412.481504]  a2 : 0000002ae76a9890 a3 : 00000000000000a0 a4 : 0000000000000000
[  412.488795]  a5 : 0000000000000000 a6 : 000000000000000a a7 : 0000002ae76df570
[  412.496035]  s2 : 0000002ae76c1000 s3 : 0000000000000000 s4 : 0000002ae76c5fa0
[  412.503313]  s5 : 0000003faa3ccd40 s6 : 0000003faa3ccd40 s7 : 0000003fcd0f55a0
[  412.510622]  s8 : 0000003fcd0f5598 s9 : 0000003f9c00ac70 s10: 0000003faa139f6a
[  412.517908]  s11: 0000003faa1ea368 t3 : 0000003faa12b85e t4 : 0000002ae76f5898
[  412.525157]  t5 : 0000000000000020 t6 : ce74ecdcb57f7893
[  412.530541] status: 0000000200004020 badaddr: 0000000000000008 cause: 000000000000000d

I prevented them temporarily by removing executable bit by sudo chmod -x /usr/libexec/gsd-usb-protection.

WebGL Aquarium runs at 4 fps with 1000 fishes. Reboot command works normally.

Then strange things started to happen.
With default snapshot 20221225T084846Z repositories the sudo apt-get dist-upgrade command makes system unusable - on GNOME Wayland I see tremendous mouse lag even in GDM3, so it is unusable.

I tried to fix this by removing manually installed packages by

sudo apt-get autopurge ffmpeg-gstreamer libsdl2 nodejs nwjs qt sdl2 v4l2test v8

so there are 5 manually (locally, but useful) installed packages:

$ aptitude search ~o
i   firefox                         - Safe and easy web browser from Mozilla    
i   img-pvr-rogue                   - imagination pvr                           
i   libreoffice                     - All modules for LibreOffice 7.5           
i   linux-headers-5.15.0-starfive   - Linux kernel headers for 5.15.0-starfive o
i   linux-image-5.15.0-starfive     - Linux kernel, version 5.15.0-starfive

But this does not remove mouse lag.

So I decided to switch to live unstable repository to get all upgrades:

cd ~/Downloads
wget -c
sudo apt-get install ./debian-ports-archive-keyring_2023.02.01_all.deb
sudo sed -i "s/^deb/#deb/g" /etc/apt/sources.list
echo "deb unstable main contrib non-free" | sudo tee -a /etc/apt/sources.list
sudo apt-get update
sudo apt-get dist-upgrade

Then cleaned up locally installed packages by

sudo apt-get autopurge libdns-export1110 libisc-export1105  libpoppler123 libsdl2 libtiff5 libzxingcore1 firefox libreoffice

to have only 3 local packages:

$ aptitude search ~o
i   img-pvr-rogue                   - imagination pvr                           
i   linux-headers-5.15.0-starfive   - Linux kernel headers for 5.15.0-starfive o
i   linux-image-5.15.0-starfive     - Linux kernel, version 5.15.0-starfive 

But it does not return graphical speed.

So I decided to install MATE with LightDM on Xorg instead

sudo apt-get install task-mate-desktop

and it is slow too.

So finally I decided to install Sway (i3-compatible Wayland compositor) by

sudo apt-get install sddm --no-install-recommends # select sddm here
sudo apt-get install sway
echo "export WLR_NO_HARDWARE_CURSORS=1" >> ~/.profile # see

rebooted and logged into it. It works fast!

I hope that all these repository related problems will be fixed.
Until then I’ll continue to use Debian sid/unstable image with MATE on Xorg from hexdump0815 on NVME SSD.

1 Like

From the release notesNote: Please avoid running apt upgrade as it will override the existing customized mesa and linux-libc-dev versions provided.”,

This is not a official Debian release it is a … “buildroot” (everything was cross-compiled from source code). And I have not fully dug into the details (yet), but I assume that the Debian image is a “debootstrap”. And that debootstrap which is pointed point in time of sid binary packages for the risc-v architecture.

By executing an sudo apt get dist-upgrade or a sudo apt get upgrade you removing patches which make the VF2 hardware work. Until probably kernel 6.4 or later an upgrade command will actually be doing the total opposite - remove functionality.

If you really know what you are doing and use “sudo apt-mark hold” on all the packages that should never be updated (The ones that have received patches from StarFive to allow functionality on the VF2 to work). Then you can start to do things like upgrade, and dist-upgrade will refuse to work (because it will remove functionality - typically the ability to boot).


Sounds reasonable.

So I would suggest developers to put some /etc/apt/preferences.d/pin-vf2 file into next image to prevent such breakage (see Debian wiki for details).
They actually know which packages came from official Debian repositories and which are locally compiled/patched (but share the same name).


They do not need that much complexity because, as @mzs noted above, this is not a production OS.

It’s an engineering release by StarFive so that people developing support for the platform have something to work with. They ship against a specific debian snapshot and specifically tell you, in the release notes, not to try an upgrade.


This Samsung monitor displays 1080p and the VF2 desktop correctly.

This Seiki monitor DOES display the 1080p. UPDATE: don’t use any hdmi to dvi adapters. It must be a pure hdmi cable.

The sound quality coming from the hdmi port:
-from firefox pointing to 432hz radio station is excellent

-from firefox pointing to youtube some Handel “Bel Contento” is excellent

From a bluetooth 5.1 dongle that I got from aliexpress unfortunately the sound quality degrades enormously.

I posted this showing the desktop running correctly with the Samsung monitor and demonstrating the sound quality is spot on from the hdmi port and from a Vention USB mic/speaker dongle.

Your monitor native resolution is 1366 x 768, which I think VF2 not supported yet? (correct me if I’m wrong)