VisionFive 2 Debian Image 202302 Released

Could you ping your visionfive2 and did you type the command?

echo ‘PermitRootLogin=yes’ >> /etc/ssh/sshd_config
systemctl restart sshd

1 Like

Yes, I can ping it. Yes I completed those commands. I also manually checked the ssd_config file and it indeed states PermitRootLogin=yes

I can log on locally/directly to the VisionFive 2 using my keyboard and monitor, that’s how I ran the commands that supposedly get SSH working over root (but not in my case). I haven’t tried logging in as user@ but unless user is already in the sudoers file I will need to login locally again to add user to the sudoers file if I actually want to do anything useful.

The point of my post is removing SSH was dumb and aggravating, and it is. Literally made no sense to do that whatsoever.

1 Like

user is in the sudoers in Debian Image 202302.

Good to know, thanks.

I still don’t understand why I can’t SSH in with root This was possible on the “Debian 69” image (or why SSH being installed and config’d by default was removed in the Debian “202302” image.

I will try SSHing in using user here in a bit

Need to get 224 MB of archives.
After this operation, 35.8 MB of additional disk space will be used.
E: You don't have enough free space in /var/cache/apt/archives/.

Any ideas?

I ran:

sudo apt autoremove
sudo apt autoclean
sudo apt clean

Still get this error message. Is there a way to increase the space in /var/cache/apt/archives/?

I am using the eMMC but the way. I used GParted to expand/resize and now the install is borked. Not booting.

I will have to flash the eMMC again, install and configure SSH again, hold back

sudo apt-mark hold xserver-xorg-core

(So I don’t kill the display)

Some how resize the partition

and then do your steps:

apt-get install ./debian-ports-archive-keyring_2023.02.01_all.deb
sed -i "s/^deb/#deb/g" /etc/apt/sources.list
echo "deb unstable main contrib non-free" >> /etc/apt/sources.list
apt-get update
apt-get dist-upgrade

This worked.

1 Like

Follow the steps in the guide to expand the root filesystem to the full disk.

But this is a using a snapshot repo, there is nothing to upgrade… Unless you switch to the updates repo (discussed elsewhere many times), which will break X windows for relatively little gain.


Yeah I think it will work if I hold back
sudo apt-mark hold xserver-xorg-core

Gonna try anyway

Nope. Didn’t work. Won’t boot now. Will have to re-flash the eMMC. Gonna put this thing away for a few weeks/months and wait for an image that doesn’t suck.

I managed to update my vf2 to the latest 2.10.4 and debian 202302.
First I could not boot the starfive-jh7110-202302-SD-minimal-desktop.img. I had updated the spi with tftpboot, looked like it was the correct u-boot, ended up using the recovery method and after that the image booted.
Changed the sources.list and upgraded some 330 odd packages, still boots after that (not using lightdm). The kernel still lacks features so have to build that, ipv6 and bridge specifically to get docker up and running.

Building the kernel with ubuntu:bionic ended up with broken ipv6.
ipv6: The unexpected relocation type 'R_RISCV_ALIGN' from PC = 000000008cdc741b
Changed the docker image to ubuntu:devel rebuilt kernel, now ipv6 works and docker seems happy. Not sure if this warning is relevant:
bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.

1 Like

I also updated the firmware and the image.
I enlarged the root partition (partition 4, last partition) with Gparted on my Linux laptop where I wrote the image to the micro SD card.
After that I mounted the root partition and added a text file to get the packages like Firefox and Libre Office. Instructions found here: VisionFive 2 Debian Wiki - 202302 Release | RVspace

chmod +x
sudo ./

As I logged in as user, I added sudo to execute the script.

Full video with explanation here:


I‘ve just received the recommended 10’ 4Lane MIPI LCD(800*1280) from Allnet China store.

Will it work with the new debian image out of the box?

Best regards

Not yet, we are still working on MIPI DSI for Debian

1 Like

Thank you for quick reply! Maybe you have some deadlines for this task? Or another image that support this display?

You can flash this image(based on buildroot) into SD card and power up. after that, input the following command to check the MIPI DSI monitor is working or not
modetest -M starfive -D 0 -a -s 118@35:800x1280 -P 74@35:800x1280+0+0@RG16 -Ftiles


never enable root ssh access.
login as a user, then su -

1 Like


Can I install Linux perf?

# apt-get install linux-tools-common linux-tools-generic linux-tools-`uname -r`
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Package linux-tools-common is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'linux-tools-common' has no installation candidate
E: Unable to locate package linux-tools-generic
E: Unable to locate package linux-tools-5.15.0-starfive
E: Couldn't find any package by glob 'linux-tools-5.15.0-starfive'
E: Couldn't find any package by regex 'linux-tools-5.15.0-starfive'

I think Debian Image 69 had it pre-installed, but I’m not sure.


It is part of the the buildroot packages:
but it is not currently selected as a package to be built:
nor in any of the the used by the buildroot Makefile

That is about the extent of my knowledge about buildroot, I guess you could read the buildroot manual and/or the StarFive Software Development Kit.

I did notice this:

But it is already enabled:

Hi. After finding the note about 4K displays and setting the right resolution, I was finally able to get into my new debian image.

if you have a 4K monitor you need to alter the lightdm config file to use a suitable resolution 1920x1080 worked for me