Ubuntu 23.10 -> error: relocation overflow.?

Using this doc: RISC-V/StarFive VisionFive 2 - Ubuntu Wiki

I was able to run the Ubuntu 23.10 installer and install Ubuntu. Grub for the installer comes up, and I’m able to run the installer and complete the install.

However, on the next steps of booting my install, I get this error: error: relocation overflow.

I run these steps as documented:
pci enum
nvme scan
efidebug boot add -b 0001 ‘Ubuntu’ nvme 0:1 /EFI/ubuntu/grubriscv64.efi
efidebug boot order 0001
bootefi bootmgr

Grub for the installation then successfully lows… But nothing works. If I select any of the bootable Ubuntu options, I see this output:
"error: relocation overflow.
error: relocation overflow.
error: relocation overflow.
error: relocation overflow.
error: relocation overflow.
error: relocation overflow.
error: relocation overflow.

Press any key to continue…"

If I go to the grub CLI, this happens:
" Minimal BASH-like line editing is supported. For the first word, TAB lists possible command completions. Anywhere else TAB lists possible
device or file completions. To enable less(1)-like paging, “set pager=1”. ESC at any time exits.

grub> restart
error: can’t find command `restart’.
grub> help
error: relocation overflow.
grub> reboot
error: relocation overflow.

If I type “exit”, I get the same error. However, ESC allows me to quit back to the menu.

Any idea on what’s going on here?

I’m completely new to RISC-V, I have a little bit of SBC experience. However, Linux has been my daily driver for over 2 decades.

Here’s what happens when I attempt to talk to the NVME drive from the serial console. It seems to work as far as I can tell as I can access the disk:
StarFive # pci enum
starfive_pcie pcie@2B000000: Port link up.
starfive_pcie pcie@2B000000: Starfive PCIe bus probed.
PCI: Failed autoconfig bar 10
starfive_pcie pcie@2C000000: Port link up.
starfive_pcie pcie@2C000000: Starfive PCIe bus probed.
PCI: Failed autoconfig bar 10
StarFive # nvme scan
StarFive # ls nvme 0:1

0 file(s), 1 dir(s)

StarFive #

I updated to the latest U-Boot provided for the board as the version that shipped with the board would not work:
StarFive # version
U-Boot 2021.10 (Nov 29 2023 - 14:51:40 +0800), Build: jenkins-github_visionfive2-20

riscv64-buildroot-linux-gnu-gcc.br_real (Buildroot JH7110_VF2_515_v3.9.3) 12.2.0
GNU ld (GNU Binutils) 2.39

1 Like

Update SPL and U-Boot through the u-boot files Ubuntu provided.

Step 1&2 may work for you my friend.

1 Like

Thanks! I just did the update steps (helps I already had tftp setup for when I was netbooting a SPARC around a year ago). Won’t have time to test if it works until tomorrow though. Will update!

The same issue I got days ago. :rofl:

Well, that fixed it! Thank you!

1 Like

Good, feel free to mention me if you get something stuck.

1 Like

Thanks, I appreciate that! Hopefully I won’t need to bother you too much. :grinning:

It seems the fan still works after powering it off, did you notice it? @Neuromancer

Yes, I’m seeing the same behavior of the fan still spinning after shutdown. I just assumed this was expected/intended. :sweat_smile:

Doesn’t bother me… I’m leaving mine running 24/7.

1 Like