Ubuntu 22.04 LTS has a RISC-V version - anyone got this running on VisionFive V1?

I am pretty sure this won’t help but if Fedora is already installed, can this Fedora "media writer tool’ create another distro ?

I did a build kernel with snap and squashfs support. Now systemd loading withoud errors.

2 Likes

After installing:

  1. sudo cp /usr/lib/linux-image-5.17.4-visionfive-foobar-26042022-1/starfive/jh7100-starfive-visionfive-v1.dtb /boot/dtb-5.17.4-visionfive-foobar-26042022-1
  2. sudo sudo update-grub
2 Likes

Broken url? linux-5.17.4-visionfive-foobar-260422022.zip — Яндекс.Диск

Update:
Ubunut Server 22.04 LTS Kernel 5.17.4

Changes:

  • Kernel: Added support for snapd & LXC
  • Reduced image size for 8GB sd cards
  • Fixed loading time
  • Fixed Failed to check for processor microcode upgrades.
  • Installed updates until 27.04.2022

How to install

  1. Download the archive
  2. Extract the image file ubuntu-server-22.04-riscv64-visionfive-27042022-1.img
  3. Install any tool to flash OS images onto SD cards. I tested by etcher
  4. In etcher select the image file and press the flash button. Wait for the process to complete.
  5. Then insert the card into the visionfive v1 board and check the result.

SSH login\password
user\star5

3 Likes

Wonderful ! Thanks.

1 Like

You should create new topic about it :slight_smile:

  • upload the file to other host because yndex slow

Do you have some more details about how you fixed this? :slight_smile:

I just set optional: true for netplan for fix this

апр 15 14:36:46 gateway systemd[1]: Starting Wait for Network to be Configured...
апр 15 14:38:46 gateway systemd-networkd-wait-online[495]: Event loop failed: Connection timed out
апр 15 14:38:46 gateway systemd[1]: systemd-networkd-wait-online.service: Main process exited, code=exited, status=1/FAILURE
апр 15 14:38:46 gateway systemd[1]: systemd-networkd-wait-online.service: Failed with result 'exit-code'.
апр 15 14:38:46 gateway systemd[1]: Failed to start Wait for Network to be Configured.
1 Like

Done.

2 Likes

I cannot create network bridge for lxd
I got

"Error: failed to create local member "lxdbr0" in project "default": Failed to run: ip link add lxdbr0 type bridge: Error: Unknown device type.

I think you need to enable Canonical Kernel which has all necessary modules enabled

I tried docker.io too and it installed but I cannot start docker service

Update:

Ubuntu Server 22.04 LTS Kernel 5.17.5-generic

Changed

  • Kernel 5.17.5
  • Kernel based on original Ubuntu server build config 5.15.0 – generic. (Included all modules and boot time increased by 2 times. From 30 sec to 78 sec on a class 10 sd card.)
  • ESP & boot partitions reduced.
  • removed cloud-initramfs-copymods

SSH login\password
user\star5

Also you can install kernel severally

I think in the future we can find good set of modules for avoid long time of boot. Generic kernel is redundant functions.

3 Likes

Thank you a lot,
Generic is good for everyone because they can use it however they want without need to rebuild the kernel

1 Like

I installed the packages and I got the following message

and after reboot the board didn’t boot

From your log:
No space left on device

Need more space on disk. About 3 GB

1 Like

Thank you for this! I just started tinkering with my VisionFive, but I have absolutely no patience for RedHat. Everything’s years out of date if it’s even packaged at all, the config files are in weird places and have bizarre defaults, etc. ad furiatum.

@jershell I notice something wired and I don’t know if it VisionFive limitation or Ubuntu 22.04

I cannot get IPv6 from the router and I tried everything from edit netplan to ifconfig command