SOLVED: Please do not upgrade u-boot/spl for 8GB DDR VisionFive2 since CMA will not allocated successfully under Debian image 202306


Well i just did this. Anyway…

I got an 8 Gig device and updated the FW to 3.4.5. I did not read the warning in time and now i cant boot.

I updated the uboot and the fw-payload file with 202303 image to 3.4.5. (newest FW.)

Worked but now i cant boot anymore. I see the Visionfive2 Boot screen for a second and then the monitor shuts of.

Later i read this small notification. Its not even labeld as warning!

Note: Please do not upgrade u-boot/spl for 8GB DDR VisionFive2 since CMA will not allocated successfully under Debian image 202306

It seems 202303 is also affected.

What does CMA mean ?

Did i just brick my device ?
How can i recover from this ?

Does any image work ?
Will a future image work ?

How can i proceed from here ?

Thanks a lot guys!

You’re most definitely not bricked. This board can always boot from UART, through the non-updatable internal bootloader. There’s a rescue image for that, which can be used to write good firmware into SPI.

Get a serial port connection if you don’t already have one. A cheap cp2104 is what I recommend.


(Linux) Contiguous Memory Allocator

1 Like

202306 SDCard image have spl/uboot on SD.
You can write a tf-card with this version AND set SDIO MODE to boot up without QSPI’s firmware.


Thanks jiangtao9999 for your answer!

So to avoid further mistakes, let me repeat what i did understand from your answer:

  • With the 3.4.5 FW i “soft-killed” my ability to boot with SPL Method. This seems to be the normal way of booting ? I did this by flashing the SPL “module” of mtd.

  • The 202306 minimal SD Card Image has a backup boot method with uboot bootloader (which i also upgraded in my previous step with the fw_update img file) but this should still work with the 3.4.5 img file correct ? Do need to press something on the keybord as i will most likely see nothing ?

  • To tell the board to use the backup boot method i have to use: SDIO Boot mode. This is achieved by the following jumper setting:
    RPIO1 = 0 (L) RPIO2= 1(H)

  • With this a 202306 minimal image will boot up and i can DOWNGRADE spl and uboot firmware to v3.1.5. Or would it be better to continue booting this way and wait for a updated firmware that does not have this error ?


Thanks! I have one somewhere of course but i never used it and have to look for it.

I read the recovery instructions but they are quite diffuse. how would i do this in Linux ? It seems they connect the uart usb and then it will be detected automaticly form the programm “Tera Term” and this will ask for a file to flash of some kind ?

How can i facilitate this in Linux ?

v3.0.4 is the one that is on the image file for 202306, v3.1.5 was a released after 202306 image and has not been used in any public images from StarFive.

1 Like

Thank you! So it s save to downgrade the Firmware i assume ?

1 Like

OK i was able to boot 202306 minimal image with this method. Wifi works also. now im debating downgrading the FW…


1 Like

VF2 is a dev-board . Support muilit ways boot is it basic feature.
IF you want to “save money”, the final product can be removed the QSPI storage.

It is not “backup method”. It is basic feature. SDimage is used this to make it is run fine.

It is not “backup” again. It is basic feature. :wink:

If you do not want boot from NVME, I suggest that use SD mode.
SDmode/eMMCmode are not depend on QSPI’s bootloader.

1 Like

Thank you all for your timely and warm resonse!
I downgraded to FW 3.04 and all works again!
I switchd back to SD Card boot mode and it works!

1 Like