Reset button does not work on V1.3B, works on V1.2A when powered via GPIO

If I power my board via GPIO directly from 5VDC source (either 2 or 4 as +5V and 6 as GND), I can reset board with RESET button on V1.2A but not on V1.3B. It simply ignores it.
When I power both from USB-C socket, everything is okay.
Quickly looking at both schematics I fail to see a difference in logic, aside from appearance of connection to push button from U26:EN on V1.3B while on V1.2A schematic it is missing (which should invert my results).

Did I miss something? It is actually safe to power it that way I described?

Aside from that, both boards and systems work as usual.

1 Like

In the VisionFive2 Quick Start Guide document it says “GPIO Power In 5 V DC via GPIO header (minimum 3 A)
But in the JH7110 Datasheet document it says “Note: The maximum current that a GPIO pin can afford is 3 A” (It should have been said in relation to the GPIO voltage out pins, because “Each GPIO pin can safely draw a maximum current of 32 mA, whereas the maximum current draw when all GPIOs are combined should be less than 100 mA. Please take this into account or otherwise, you will end up destroying the GPIO pins.” - according to the VisionFive2 Quick Start Guide).

So I’m wondering if the power pins in the 2.54mm 40-pin header have a maximum rating of 3A. That if you wanted to supply 30 watts to the board that you would need to use both of the +5 volt pins (2 and 4), along with any two of the seven GND pins - (6, 9, 14, 20, 25, 30, 34).

1 Like

True, but reset button still doesn’t work on V1.3B in such setup :smile:

It does if you hold it for 3 seconds :slight_smile:

I held mine for tenths of seconds to no avail… :frowning:


@strcat i also noticed that the button does nothing when powered via a PoE hat (and thus trough the pin header)

Reading the schematic i noticed that that the button is wired to an resisitive divider fed from LDO out (low dropout, max 100mA) of the power chip that is closest to usb-c (U26, NB679GD). that chip is not used when powered via the pin header, so the button has no supply voltage in this state (confirmed by measuring on the board) [edit: power source is most likely incorrect, see later comment]

got a link to the 1.2A design schematics? i’d like to find out how the old revision made the reset button work as there are a ton of options

1 Like

Yep, they still host it even if no link visible anymore:



ok, had a closer look: on page 18 the switch is depicted. it looks like one connection was was pulled up to 3.3V (RTCLDO of the main PMIC AXP15060) via a 4.7k resistor that is noted as NC in the current schematics.
seems like the button is hardware disabled on v1.3b powered from the pin headers, maybe someone from starfive can give a reason for that


Nice find. Together with that, you can clearly see that they added PWER_EN node to U26 buck IC (page 22 of each pdf), which, I guess, provides 5V rail (through Q10 on same page). Sadly, this plan did not worked out: the push button now does not generate SYS_RSTN signal and system just continues to operate like nothing happened if 5V is directly biased. I guess restoring that area to V1.2A configuration might solve this.

EDIT: also needs to check the area of PMIC, especially PWRON, which is also now disabled. Probably nothing is related to SYS_RSTN, but old behavior did shut down PMIC.

Since all elements in the area are of 0603 size, it might be quite difficult for average user. You have to get at least soldering tweezers for that.