No boot after trying to flash Software 3.8.2

Hello everyone,

I tried updating to the new software/firmware package 3.8.2
It seems the SPI/uboot partition layout has changed and I cannot boot the board anymore.
I tried re-flashing everything using the Recovery Guide hoping that it would overwrite the flash with the most current layout but it seems it didn’t.

Boot log SD boot mode: U-Boot SPL 2021.10-dirty (Oct 30 2023 - 09:07:16 +0000)LPDDR4: 8G version: g8a -
Boot log SPI boot mode: U-Boot SPL 2021.10 (Oct 31 2023 - 19:41:27 +0800)LPDDR4: 8G version: g8ad50857 -

What am I missing and how can I recover the board?

Thanks in advance!

U-boot log indicates it can’t find vf2_uEnv.txt This file should be in the boot partition (3rd partition on the SD card with partition type EFI System) If you only updated the 1st U-Boot SPL and the 2nd partition OpenSBI+U-Boot, and reusing the boot/root partitions, you’ll need to copy this file from the v3.8.2 image.

yes, check your 3rd partition if there have a vf2_uEnv.txt.

i had some problems getting the image running too. from my tests it looks that antivirus on windows (used for download image and flashing onto ssd) did strange things. flashing image onto ssd worked properly once antivirus was disabled.

not sure, if that helps