New user, VisionFive 2 working with microSD, not NVMe

Just got my VisionFive 2 yesterday. Even though I ordered in late March 2023, I still received an early access board, which needs the firmware update. I wasn’t able to get the sdcard.img to attach to DHCP over ethernet (over either port), so I had to dig out a USB-> serial cable, and sure enough, it was working fine, just wasn’t activating the ethernet ports.

I can run the starfive-jh7110-202302-SD-minimal-desktop.img when written to a 32GB microSD, but it wasn’t working with another 64GB card. Further, I can’t get the starfive-jh7110-202302-eMMC-minimal-desktop.img to boot from two different NVMe cards I tried. The error on the serial console is

dwmci_s: Response Timeout.
BOOT fail,Error is 0xffffffff

(I’m toggling the DIPs) I’ll chalk this up to media incompatibility, but haven’t had issues with either the 64GB microSD or the NVMe SSD’s I tried on other platforms. I’m posting this to a) encourage new users of the early access platform (even as recent as late March 2023) to go the serial port route, and b) try different media if you’re seeing BOOT fail messages.

1 Like

Booting from NVMe is currently not yet supported.


That explains it! The eMMC vs NVMe support went in one ear and out the other as I was sifting through how-to’s. Thanks. It’s looking like NVMe isn’t showing up at all when I boot from microSD with the NVMe card inserted. Is that just a matter of kernel configuration?

1 Like

I must have overlooked that:

It should at least be possible to create a partition and use the NVMe, if not as a boot drive, then at least after boot. If it is not displayed at all, either the power supply is too weak or there is a problem with the NVMe.


It is/should be fairly trivial to keep root on the NVMe while still booting off something else (I haven’t done it as I’m constantly trying different distros so SDcards are easier).

This is no longer true. I saw someone on twitter booting linux directly from nvme ssd using the new u-boot in the SPI flash.

Looks promising, but for the moment I’ll stick to SD boot, NVMe root.

Edit: Also, it says they are using, so not sure how this applies to Uboot and co.

Now we can boot nvme directly from u-boot. NVME Boot using VisionFive2 Software v2.11.5

1 Like