Issues installing official Ubuntu 23.10 image (Help)

Hey guys,
i am trying to install the new ubuntu 23.10 server image for my visionfive 2 and i had debian installed previously and that worked. Now i downloaded the live installer from here Download Ubuntu for RISC-V Platforms | Ubuntu, flashed that file to an sd card using balena etcher (i am running on windows) and tried to boot with an nvme in the m.2 slot. The sbc boots, but i only get errors and it ends up in the u-boot cli.
Same issues happen if i remove the nvme or use the preinstalled ubuntu image instead of the live installer

I can see the error “Failed to load ‘/dtbs/starfive/jh7110-visionfive-v2.dtb’” but i have found nothing about this issues and have no idea how to solve it.
Btw, i am working on windows and therefore would need a solution, that works on windows.

1 Like

I just went through a few hoops to put the image on the nvme (ssd). I mounted to the EFI partition to have a look and it looks like the path is different, starting with dtb/ not dtbs/

root@starfive:/mnt# ls dtb/starfive/
jh7100-beaglev-starlight.dtb jh7110-starfive-visionfive-2-v1.2a.dtb
jh7100-starfive-visionfive-v1.dtb jh7110-starfive-visionfive-2-v1.3b.dtb

but not sure this is the same image you are using. I got this from

Oh, And here is the starfive build boot dir:
oot@starfive:/# ls boot/dtbs/starfive/
evb-overlay jh7110-evb.dtb
jh7110-evb-can-pdm-pwmdac.dtb jh7110-fpga.dtb
jh7110-evb-dvp-rgb2hdmi.dtb jh7110-visionfive-v2-A10.dtb
jh7110-evb-i2s-ac108.dtb jh7110-visionfive-v2-A11.dtb
jh7110-evb-pcie-i2s-sd.dtb jh7110-visionfive-v2-ac108.dtb
jh7110-evb-spi-uart2.dtb jh7110-visionfive-v2-sof-wm8960.dtb
jh7110-evb-uart1-rgb2hdmi.dtb jh7110-visionfive-v2-wm8960.dtb
jh7110-evb-uart4-emmc-spdif.dtb jh7110-visionfive-v2.dtb
jh7110-evb-uart5-pwm-i2c-tdm.dtb vf2-overlay

Can you install Windows Subsysten for Linux and see if you can access the micro SD card, after you have written the image?

Does Ubuntu 23.10 now support HDMI output? I never understood why Ubuntu 23.04 only supported serial console…like why? :smiley: when other distros had no problem with drivers and output to HDMI.

Hey, yes i can install wsl, though i havent used it yet and therefore am not sure, how i can mount the sd card/usb adapter to the wsl distro

Hello, I actually seem to have a similar issue. What I did try was use these commands:
From the wiki, but I manually changed the mmc device:partition ID so it can find the correct device tree and efi file, after that it booted with the supplied command.


Check that integrity of downloaded Ubuntu image, verify flashed SD card for errors, check compatibility with VisionFive 2 and search for VisionFive 2 Ubuntu installation guides