Issue updating U-boot

I’m having problems trying to update U-boot. Initially I was unable to boot Fedora, but then I read This and attempted to update U-boot. However, when I follow the steps outlined in the official docs I get stuck at the minicom screen and cannot do anything. I fear the board came DOA…

It seems that uboot has not been updated successfully. You can try again. Please send the uboot file within 20s.

Maybe you should recover the bootloader refer to Appendix C: Recovering the Bootloader

This is attempting to update U-boot. According to the docs:

  • After the hardware connections mentioned above, power on the VisionFive and you will see the startup information as follows.

    Figure - Example
  • Press any key as soon as it starts up to enter the upgrade menu. In this menu, you can only update u-boot.

I never see the ddr test, pressing a key does nothing and I never get to the menu for flash programming. I have even attempted recovering the firmware, but it didn’t do anything.

Thank you, I have tried that though.

Recover the firmware, UART cable needs to be connected to the debug serial port( Speed: 9600),which is in front of the BOOT MODE button. Press the BOOT MODE button while turning on VisionFive.

I tried that again, with the same results :confused:. Below is the completed recovery on linux.

And attempting to update U-boot

I have tried to manually access the recovery screen as described in the windows section of firmware recovery, but I don’t receive any output in the terminal window

First press and hold the BOOT MODE button, and then insert the type - C to power visionfive,Don’t forget to set the speed of debug serial port to 9600.

Unfortunately, I did that and still nothing besides the bootloader version.

what does the serial port output when you get and power up the board at first

Hi Micheal,
Had to create a new account temporarily until my original account can post again – reached the post limit for a new user’s first day.

It doesn’t give me anything besides the bootloader version.