Is my board toast?

I had the board working for some time, but now I can’t get it to boot. I was booting in QSPI mode (00 on the switches) when I rarely get anything more than this message:

U-Boot SPL 2021.10 (Feb 12 2023 - 18:15:33 +0800)

I try to install a new bootloader as described here but the only response I get after uploading with xmodem (in minicom) is:

JH7110 secondboot version: 221205-74596a9
CPU freq: 1250MHz
idcode: 0x1860C8

I am out of options now how to proceed. How can I tell if the board is salvagable or not?

Since it previously booted after having been powered off, I thought heat was an issue and I attached a fan, but now it almost never boots, even after a significant time powered off.

Try changing it to boot from SD card or nvme

I got a board from Waveshare, and it will not boot either. I have tried to update the firmware, but it’s not moving once the bin is uploaded. When I tried to use Mobaxtem kept getting CRC error. I install Tera Term, it not giving the CRC, but I am getting the following.

It’s just sitting ther, this is same thing I was getting when I had set to boot from SD.

When I tired to boot from emmc, I get error loading. I did burn an email to a 64 GB emmc module. Maybe there is a bad batch? I only had my board a week or so.

The sad part, I bought to to review on my channel, because I heard a lot of cool, but until I get this fixed. I can’t and will not recommend this.



This is the error when I tried to boot my emmc

I am using the latest Debian image for SD for this.


This is my error booting SD, it just hangs like the firmware.

I am using the latest Debian image for SD for this.

I did not recognise your original firmware. So I downloaded them all 10 of the publicly released versions from It was not an exact match for any of them. But if I had to guess I would say that it was probably somewhere between VF2_v2.8.0 and VF2_v2.10.4.

VF2_v2.4.4/u-boot-spl.bin.normal.out   U-Boot SPL 2021.10 (Dec 08 2022 - 17:27:48 +0800) 
VF2_v2.4.4/visionfive2_fw_payload.img  U-Boot 2021.10 (Dec 08 2022 - 17:27:48 +0800)
VF2_v2.5.0/u-boot-spl.bin.normal.out   U-Boot SPL 2021.10 (Dec 25 2022 - 20:59:18 +0800)
VF2_v2.5.0/visionfive2_fw_payload.img  U-Boot 2021.10 (Dec 25 2022 - 20:59:18 +0800)
VF2_v2.6.0/u-boot-spl.bin.normal.out   U-Boot SPL 2021.10 (Jan 08 2023 - 18:04:54 +0800)
VF2_v2.6.0/visionfive2_fw_payload.img  U-Boot 2021.10 (Jan 08 2023 - 18:04:54 +0800)
VF2_v2.8.0/u-boot-spl.bin.normal.out   U-Boot SPL 2021.10 (Jan 19 2023 - 04:09:41 +0800)
VF2_v2.8.0/visionfive2_fw_payload.img  U-Boot 2021.10 (Jan 19 2023 - 04:09:41 +0800)
VF2_v2.10.4/u-boot-spl.bin.normal.out  U-Boot SPL 2021.10 (Feb 27 2023 - 22:53:48 +0000)
VF2_v2.10.4/visionfive2_fw_payload.img U-Boot 2021.10 (Feb 27 2023 - 22:53:48 +0000)
VF2_v2.11.5/u-boot-spl.bin.normal.out  U-Boot SPL 2021.10 (Mar 24 2023 - 01:42:56 +0800)
VF2_v2.11.5/visionfive2_fw_payload.img U-Boot 2021.10 (Mar 24 2023 - 01:42:56 +0800)
VF2_v3.0.4/u-boot-spl.bin.normal.out   U-Boot SPL 2021.10 (May 31 2023 - 16:54:00 +0800)
VF2_v3.0.4/visionfive2_fw_payload.img  U-Boot 2021.10 (May 31 2023 - 16:54:00 +0800)
VF2_v3.1.5/u-boot-spl.bin.normal.out   U-Boot SPL 2021.10 (Jun 21 2023 - 13:42:04 +0800)
VF2_v3.1.5/visionfive2_fw_payload.img  U-Boot 2021.10 (Jun 21 2023 - 13:42:04 +0800)
VF2_v3.4.5/u-boot-spl.bin.normal.out   U-Boot SPL 2021.10 (Aug 08 2023 - 16:01:18 +0800)
VF2_v3.4.5/visionfive2_fw_payload.img  U-Boot 2021.10 (Aug 08 2023 - 16:01:18 +0800)
VF2_v3.6.1/u-boot-spl.bin.normal.out   U-Boot SPL 2021.10 (Aug 31 2023 - 12:55:45 +0800)
VF2_v3.6.1/visionfive2_fw_payload.img  U-Boot 2021.10 (Aug 31 2023 - 12:55:45 +0800)

My one question would be why did you choose to use jh7110-recovery-20221205.bin instead of jh7110-recovery-20230322.bin The document you linked to says “Transfer the latest recovery binary (jh7110-recovery-<Version>.bin) by XMODEM. <Version> indicates the version number of the recovery file. Make sure you use the latest version.

If it was my board I would try and boot it using the previous 2023-06-16 image file ( ) with my boot switches set to use SDIO3.0, that way I might be able to tell if there was a problem with the 1-bit QSPI NOR Flash or a problem elsewhere on the board. If it can boot using the SPL+U-Boot and U-Boot+OpenSBI loading them from a MicroSD card (or an eMMC module) then that would be a strong indication that there was a fault with the QSPI NOR Flash. The (current) latest image VisionFive 2 Debian Image 202308 does not support loading and booting the firmware from MicroSD nor eMMC, because it does not work 100% of the time, on all MicroSD cards and all eMMC modules it has been removed. But using the previous image might help in determining if the fault is elsewhere on the board or with the onboard QSPI Flash.

link not to use for this test: VisionFive 2 Debian Image 202308 Released (latest)
link to use for this test: VisionFive 2 Debian Image 202306 Released (previous)

Thanks for the long reply @mzs , however, that did not work. I get only

U-Boot SPL 2021.10-dirty (Jun 11 2023 - 07:44:44 +0000)

I’m thinking there’s something serious problem with the board.

1 Like