Is my board DOA?

I connected a USB-C power adapter (5V/3A), the red LED turns on solid but my monitor doesnt even detect a signal from the HDMI. Nothing from the serial port on boot using a TTL adapter, tried loading both the newest and oldest debian images to an SD card, The SoC starts to get a bit warm but otherwise nothing seems to be happening. Is my board dead?

did you connect the ttl adapter gnd to GND, tx to RX and rx to TX ? for me a putty MobaXterm session then worked proprtly (look into manual for the connection settings)

i had quite similar issues. i then tried to jumper all different options (0-0, 0-1, 1-1, 1-0) and one of these worked. after flashing to the 3.1.5 firmware (as far as i remember) , all worked properly

hope this helps


I have confirmed 3.1.5 is still the most recent firmware. I’m not sure if you are trying to use the Debian images from however if you are, try getting the sdcard.img file from Releases · starfive-tech/VisionFive2 · GitHub and writing that to a sdcard and attempt booting from that. This has a full working image and utilities to flash the firmware (however I believe you will still need to download the u-boot-spl.bin.normal.out and visionfive2_fw_payload.img files from the same site as above and copy them to that microsd after it has been written.) I have used this method numerous times on both the VisionFive2 and the Star64. You will definitely want a TTL adapter for this. Good luck and if you need more information let us know.

1 Like

So it seems whoever made my USB-TTL converter thought it would be helpful to mark the TX and RX pins swapped around. After figuring that out I managed to update the firmware using the tftp server method described on the github. After that, everything worked flawlessly.

On another note, the wifi dongle that starfive offer with the board seems extremely slow and flaky. Has anyone else had this issue?

The WiFi dongle I got with mine has worked fine since I got the board. It has been connected continuously to my AP for nearly 10 months at this stage. The only time it has been disconnected from WiFi is when I upgraded the OS.

user@starfive:~$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 3452:6600 ESWIN 6600U
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
user@starfive:~$ uname -a
Linux starfive 5.15.0-starfive #1 SMP Wed Aug 23 11:18:20 CST 2023 riscv64 GNU/Linux

It does generate the odd message on the serial console, but that is not an issue for me.
I’m running “VisionFive 2 Debian Image 202308” and I double checked and the SPL/U-Boot binaries I installed (before I installed the newer OS) was v3.6.1 (which would have been the version that was recommended for the 202308 image).

The ESWIN 6600U chipset firmware currently used on the VF2 board is from sometime before 2022-10-31.

user@starfive:~$ md5sum /lib/firmware/ECR6600U_transport.bin
02f67eb1fcb6a549d49f29e277feec36  /lib/firmware/ECR6600U_transport.bin

This is most definitely not the latest firmware, but it looks like the API may change enough between firmware revisions that you can not just change the firmware version without modifying the driver source code to match. And if you think about it, that has very little to do with the VF2 board and the JH7110 SoC, so StarFive would probably not invest resources into that area unless there is a major problem. My guess would be that a later firmware revision and matching driver patches could yield higher performance.

But at the end of the day the device is only a USB 2,0 High Speed device (which is half-duplex). So, allowing for ACK packets, the theoretical maximum throughput is going to be a lot less than the 40MB per second (320Mbit/sec) of data streaming from a hard disk or SDR in one direction only. I’ve done no testing whatsoever but my gut feeling would be that it would probably end up being a lot closer to 20MB per second (160Mbit/sec).