Img-gpu-powervr-bin-1.19.6345021.tar.gz wrong sha256 hash

Perhaps a FAQ but I did not find anything regarding this issue. I tried to build buildroot-initramfs for the new v3.8.2 release but it stops immediatly with an error regarding the sha256 sum of the firmware blob:

ERROR: img-gpu-powervr-bin-1.19.6345021.tar.gz has wrong sha256 hash:
ERROR: expected: 9dcaf2084b13e59c4e50a4a288f5de56f8e9ee631627a3e818591675bf61311a
ERROR: got     : 3e654c827e117e4b0e8ddba8f9d477241087e4cee2f7db307e7fb8da7d9d2259

Both submodules are on tag VF2_v3.8.2
Could anybody please tell me, what I’m doing wrong here?


Try installing git lfs.


Hmmm…is installed…but now as you say it I’m not really sure I did that prior to cloning the repo :thinking:

1 Like

Nope…that has not been the problem…sha hash problem persists. Any further hints?

Ok, found the reason…the download site really does not contain that binary blob for the firmware, so the download fails:

--2023-11-04 20:25:35--
Auflösen des Hostnamens (… 2606:4700:20::681a:25, 2606:4700:20::681a:125, 2606:4700:20::ac43:4838, ...
Verbindungsaufbau zu (|2606:4700:20::681a:25|:80 … verbunden.
HTTP-Anforderung gesendet, auf Antwort wird gewartet … 404 Not Found
2023-11-04 20:25:35 FEHLER 404: Not Found.

1 Like

I tried. Sorry.

1 Like

I need to change this file :


And modify first lines as follow :


that will download file from GitHub - starfive-tech/soft_3rdpart

1 Like

it is caused by the hash is different between your local and remote.
maybe you can updare your branch of buildroot and soft_3rdpart to the latest release,the hash will update.