Dead board or just not enough power?

My Vision 2 was delivered ages ago but for various reasons have only just got around to trying to boot it - with no success.
The red light comes on and the ethernet port blinks for packets but I get no HDMI output and no sign that it has configured itself on the network. Keyboard and mouse don’t light up either.
Feels like a dead board but I wonder if its just a lack of power as I can make an powered USB extension flicker briefly on pressing the reset.
Is there any way of being sure as to what is going on?

2 questions


I’m afraid I tried both of those. Twice now (ie reformatted the card and tried again). Is there any simple test I can do to see if the device is working at all? I suppose attach the USB cable as a null modem cable and run a serial terminal? Anything else?

1 Like

You absolutely need to have a serial console to have any u derstanding of what might be going on.

Out of the box, you should not expect anything on the hdmi port, but you should be able to get networking from a properly created sdcard and proper boot switch settings.


I also recommend to check what is happening on the serial port. Also it would be the best way to update the firmware if needed

But if in the Serial boot there is no traffic on the serial port, you probably can think this is a DoA device.

After a bit of messing about I got this on the serial terminal:

dwmci_s: Response Timeout.
BOOT fail,Error is 0xffffffff

So it seems the board isn’t dead yet… will keep going.

I would double check that the boot switches are in the correct location for a MicroSD card (number 2 <= RGPIO_0 and RGPIO_1 => number 3). And if they are then my next step would be to try a different MicroSD card.

I set both switches to low and got a lot of output, though ultimately the boot failed as it was unable to mount the block device - so I know that the board is very much alive and I just need to get the settings right now.

U-Boot SPL 2021.10 (Oct 31 2022 - 12:11:37 +0800)
DDR version: dc2e84f0.
Trying to boot from SPI

OpenSBI v1.0

/ __ \ / | _ _ |
| | | |
__ ___ _ __ | (
| |
) || |
| | | | '_ \ / _ \ '_ \ ___ | _ < | |
| || | |) | __/ | | |) | |) || |
/| ./ _|| ||/|____/|
| |

And working now… thanks for your help everybody

@mcmenaminadrian, for the benefit of others that may stumble upon this thread, please link to what you confirmed was the solution. Forums like this work by the askers getting promoted to the answerers over time.

I think a lot of people really aren’t expecting this to be like an SBC - and unlike a PC - in that they ship without an OS and without the ‘brains’ to even splash pixels to a monitor by default, so there is no “Hello, and welcome to Clippy!” style screen guiding people to the next step.

Honest answer: not quite sure. It may have been I got it wrong the first time because after I connected the serial/null modem cable and used the tty and reverted to the default settings it seemed to work. My advice would be, though, if in doubt attach a serial terminal.