Armbian Release

I’m trying Armbian’s “testing” release for Vision Five 2 available since yesterday. To make it work I had to set the dip switches to 0 0 but I tried and after a first login via ssh as root it loaded the gui.

Test in progress on micro SD, ah I had to try two or three micro sd because with some it didn’t load me, I have to understand why the dip switches both set to zero allow loading.

Armbian Link
armbian vision five 2


What amount of memory You have on Your board? is it detected correctly?

Oddly i dont get any video from either minimal or desktop image, but it does boot ok and i can get to it via SSH. is it outputting some odd frequency perhaps? ( i remember having that problem with v1 of the board at first. )

And any chance this image might boot from eMMC if DD’d to one?

This is usually done with armbian-config, but maybe it doesn’t work yet.

Tried that before i asked :slight_smile: armbian-config is missing at the moment, but armbian-install is there, however it failed due to missing uboot files on the SD card.

1 Like

ok, but what amount You have on board?
As I said on mine there is 8GB and only 4GB detected.

As far as I remember I was able to run it from eMMC just by preparing loader and eMMC.

I have the 8GB version, but Armbian reports 4GB (3.8)

The fix for the incorrect memory being displayed is discussed under this issue

1 Like

Thank you! Will check it out.

Armbian Desktop, boot from Micro sd is working even though quite slow response. Thanks !!
However, Nvme SSD is not recognized(time out error).
Eth0(Gb LAN port) is not connected to Internet while eth1(100M LAN) is connected to Internet.

for those who asked, I have a board with 4GB of ram and they are correctly recognized.

I can say that the GUI is practically not usable due to the slowness, but I imagined it because the armbian image belongs to the testing category and surely the road will be long before having a performing image on the GUI environment.

I didn’t understand why I was able to boot only with the dip switches at 0 0 but this doesn’t interest me.

the idea of this post is to share the birth of the armbian image.

I haven’t tried uploading the image to the eMMC because I still haven’t been able to boot with the official image 032023 and I’ve opened a specific post.

when i manage to boot from eMMC i will also try to load armbian on eMMC and i will let you know

1 Like

Where exactly are you stuck at? I am running Armbian using eMMC. I also have the latest firmware flashed (v2.10.4). I did not even have to play with the switches to get anything booting. Debian 202302 also works for me out of the box on eMMC and also microSD card.

for my above question about eMMC, ya just a DD to the eMMC works fine. armbian-install fails, but since DD works, who cares :wink:


Is this meant to be a date used as version? The order hurts my eyes.

They really should take a look at ISO 8601.


Another option is to use this build of Debian 12 Bookworm:

This, same as all available Debian images around, is Debian Sid/unstable, not Bookworm/testing. The Debian repository ships riscv64 packages only via unofficial ports in Sid/unstable :wink:. But this fact is unrelated to eMMC boot, of course.


my trials with armbian are stalled because the GUI is basically unusable by how slow everything is. I’m back to the official debian image.

in some time i will try to see the progress of armbian. as far as the eMMC is concerned, I doubt that there is some integrity problem on my eMMC module because even with armbian, after loading the image with dd, the image does not start, leaving the dip switches on 0 0 and removing the micro sd.

at this point I focus on my other post related to the official debian and my problem with eMMC, in the next few days I will finally be able to publish the logs obtained with the serial.