Alternatives to balenaEtcher for risc-v?

Is there a way to transfer the recent img file for nvme from a running system on the SDcard?
I have tried with gnome-disks, but doesn’t seem to work (it had failed me in the past), and so also dd.
balenaEtcher is available for x86, but not for RV, so I would need to plug the nvme on another machine, while it would be easier to do it directly from the running system.

dd, cat, pv to name but three.

1 Like

as i have mentioned, i tried dd, and doesn’t seem to work.
my syntax: sudo dd if=starfive-jh7110-202306-nvme-minimal-desktop.img of=/dev/nvme0n1 bs=1M status=progress conv=fsync
is it likely that the nvme is not recognized at boot time, even if later it is?
I will try anyway with another nvme stick

Are you using a Quick Charge or a PD power supply? I have had similar problems with various Quick Charge 3.0 power supplies.
Please try a PD Charger.

1 Like

The last time I wanted to use BalenaEtcher on a platform it was not available for, I just recompiled it.
It may or may not work with RISC-V.

I didn’t think about the charger: I use the one delivered with the kit, and I am not sure what kind it is.
it looks like a normal ac-dc switch power supply, with a usb jack instead of the traditional round one.
it delivers 5V 3.6A, 18W, which should be sufficient for both the Starfive2 and the nvme bar.

that was my first temptation, too, but it has dependencies, starting with Electron, and seems a long shot that everything will run smoothly.
the SD card is a tad too slow to try this…

is there perhaps a qemu vm that matches RV+Imagination gpu?

update: I have tried with a “Transcend 256GB PCIe™ Gen3 x4 M.2 SSD 2280” and with a " KIOXIA EXCERIA NVMe 500GB PCIe 3.0 Gen3x4 M.2 2280 SSD", both not working.
I have tried both the nvme and mmc June 2023 Debian images, setting the boot switches on the board accordingly (to the image selected).

Both are kind-of mentioned in the thread What kind of SSD can be used?, although it could be that the models are slightly different. For the Gentoo test, IIUC the person who tried it didn’t boot from it.

Finally, I have used dd as explained above for all tests:
sudo dd if=starfive-jh7110-202306-x-minimal-desktop.img of=/dev/nvme0n1 bs=1M status=progress conv=fsync

do I need to update the SPI flash? If so, how? Is there a document/procedure?

and thank you all for the pointers so far

EDIT looks like the firmware version in my post are already out of date the very latest looks better (if it works with the 202306 StarFive Debian):

Fixed Issues

  • An occasional kernel panic occurred when booting from NVME;
  • gst-play will jam when playing m3u8 video;

So use

$ wget
$ wget

If it does not work, just used the linked instructions.


Yes, you have to update the SPI flash.

4. Please update the SPI flash to the latest SPL/U-Boot binaries if you would like to try this nvme image (set boot mode as QSPI boot).


it worked like a charm! thank you! :champagne: :champagne: :champagne:
thank you also to @SunWukong for the same :slight_smile: