A unified reply to a question about the display of debian69

@tommythorn sorry for late response.
Generally, xrandr couldn’t be modified default resolution and you need add a auto script like this

root@starfive:/etc/xdg/autostart# cat default_pixel.desktop
[Desktop Entry]

and the pixel.sh contains how to use xrandr to indicate a specific resolution like this:

root@starfive:/etc/xdg/autostart# cat /root/pixel.sh
xrandr --output HDMI-1 --mode 1280x720 -r 50

reboot and hope that works


have the same Issue.
I dont even get any Output.
Tried all steps mentioned here.

Here is my Post:

Thanks for the heads up! Worked like a charm! Dell U3219Q here …

1 Like

I was following the steps here but didn’t make any progress.

modetest -M starfive -D 0 -a -s 116@31:1920x1080-60.00 -P 39@31:1920x1080@YUYV -Ftiles

Works for me…It displays the pattern that Tommy also posted.

However setting lightdm.conf does not lead anywhere after a reboot.
If I try running sudo xrandr -s 1920x1080 I just get the Can't open display message.

Any further advice on debugging this?

Can you try to flash a latest version of debian VisionFive 2 Debian Image 202303 Released(latest) and set the SD boot mode to start up?

Thanks Michael that works perfectly!
The colors were a bit weird on initial boot up but after change the resolution that seems solved.
Oh and I needed to adjust the dip switches as you mentioned in the release post.

I see you added support for 4k resolution now.
Not sure how “hardcoded” that is.
The 1440p monitor I’m using seems to only go up to 1080p with the VisionFive 2.

Ok the pink tint comes back after some minutes and can seemingly only be removed by setting the screen resolution again.
Is this a common issue?

you can run the script under /opt and reboot.