1st boot no X

I am following the quick start guide and have dowloaded and booted the “starfive-jh7110-VF2_515_v2.5.0-69.img”.

I cannot get into Xorg. I have successfully ssh-ed into my system. I installed htop and can see /usr/bin/X is using about 0.7% of my CPU%. and /usr/sbin/lightdm has a few spawned instances each using about 0.1% of my CPU. Overall CPU usage is at 2%.

However on my monitor connected directly to my VF2, I see a black screen with a mouse arrow in the center. I am unable to move the mouse and typing into my keyboard doesn’t do anything either.

I’m not sure what to do to get things progressing toward a usable Debian desktop.

Any help would be greatly appreciated.

1 Like

Probably better to try with the latest release.


Try exactly this:

Then follow it by burning the new debian image.

Why? Well the new v3.0.4 firmware is what you should be running first of all.
It will help get the best experience with the newer debian image.


  • After plugging in the power into the sbc, press and hold shift while it’s booting to ensure console displays progress.
  • If you feel console output has stopped and not progressing during the boot, then press enter a few times so that the console progress continues.
  • I have experienced about 2-3 minutes of console output progress before it clears the screen to detect the monitor resolutions for the wayland/gnome desktop. Then another few minutes later, the gnome desktop appears. You may experience a weird jagged font display, but once you go to display settings, you choose another resolution/hz preferrably 1080p and the display and font will be crystal clear.


1 Like

One thing to keep in mind is that this is an engineering release based on Debian. It is a custom Debian based environment generated so that developers can write and debug code on real hardware (so never do a sudo apt-get upgrade you will end up removing working packages and replacing them with standard packages which do not yet know how to support the JH7110 SoC (System On a Chip) nor any of the features on the VisionFive 2 board.

Debian does not and will not officially support any RISC-V boards until Debian 13 (Trixie).

By the time kernel 6.5, or possibly 6.6 or even even later, are standard mainline or better yet longterm Linux support kernels that will be when this board is fully supported with most standard Linux distributions. And StarFive have been doing some totally outstanding work to make that happen.

1 Like

Didn’t realize that would break things, thanks!

Tried following instructions. Just to be clear. I reflashed my SD card from https://debian.starfivetech.com/ [OneDrive] Engineering Release → 202306 → SD → starfive-jh7110-202306-SD-minimal-desktop.img.bz

I unzipped and reflashed my SD card. On powerup, the Red LED comes on as usual, the ethernet lights up, however the green LED is not lighting up (which I assume is the processing indicator LED?) This time zero hdmi output and ssh is timing out so I cannot connect that way either.

Did you change the boot switches from the factory default of reading an ancient firmware from the onboard 1-bit QSPI NOR FLASH to reading the latest and greatest firmware from the SDIO3.0 (first two partitions on the MicroSD card).

I hadn’t messed with the dip switches at all. They appeared to be in the ON position - toward the power plug. I just switched them to OFF away from power plug. is that correct?

Oh my fivestars that worked!

1 Like

That would be telling the board to attempt to boot using the UART.

What you need is the top switch (RGPIO_1) towards the power connection and the bottom switch (RGPIO_0) away from the power connection.

One last question, if I go nvme, is that the same dip switch config as SD or will I need to again update the dip switches?

For NVME you will need to upgrade the firmware in the onboard 1-bit QSPI NOR FLASH, and then change the switches back for booting from the QSPI FLASH.

The latest SPL+U-Boot and U-Boot+OpenSBI firmware, at the time of writing, can be found at https://github.com/starfive-tech/VisionFive2/releases

The firmware you will need are u-boot-spl.bin.normal.out (129KiB - SPL+U-Boot) and visionfive2_fw_payload.img (2.82 MiB - U-Boot+OpenSBI).

Commands to run from a working OS on the VF2 to upgrade the firmware code in the onboard QSPI FLASH are:

$ sudo apt install mtd-utils
$ wget https://github.com/starfive-tech/VisionFive2/releases/download/VF2_v3.0.4/u-boot-spl.bin.normal.out
$ wget https://github.com/starfive-tech/VisionFive2/releases/download/VF2_v3.0.4/visionfive2_fw_payload.img
$ sudo flashcp -v u-boot-spl.bin.normal.out /dev/mtd0
$ sudo flashcp -v visionfive2_fw_payload.img /dev/mtd1

(If anyone is reading this post in the future the above commands will probably be out of date, so always read and use the latest Official StarFive VisionFive 2 Quick Start Guide which can be found at https://doc-en.rvspace.org)