Since Debian Image 202403 onboard LAN do not connect

what did i miss

Board has 100 and GB adapter, remaining in connecting status

Hi,after update the spl and uboot.
Has this problem been solved?

1 Like

Yes … worked fine. had a look onto git later and now the u-boot/spl files can be downloaded.

looks like many others have same issue too. i will note down on my wiki. i will let all know, once a few articles are there. — is a subsection on my wiki for the SoC s.

ok, Thanks

1 Like

What is the fix? I downloaded the 202405 image and Ethernet will not connect on it.

1 Like


long story told short:

you need to have a look to update u-boot and spl to the latest version as outlined in VisionFive 2 Debian Wiki - 202405 Release | RVspace

have a look in StarFiveTech – now seems included there in the flash folder

1 Like

For the “Through flashcp Command” option, how do I run apt install mtd-utils without first having an Internet connection?

Why doesn’t the Debian image ship with mtd-utils? It seems like a pretty essential package…

EDIT: I was able to install mtd-utils by manually downloading these deb files and copying them to a USB flash drive:

After installing these I was able to follow the flashcp instructions and then Ethernet worked.

1 Like

I have 2 SSDs … so i switched to the last working (for me) image 202311. Could also have done by using sd cars with 202311.

Sorry that i did not mention.

1 Like