No output through HDMI-VGA adapter on Debian

I don’t get any output for my VGA screen on Debian through HDMI-VGA adapter (not even any text on the boot is seen). With Fedora image it works fine.

On Fedora xrandr says HDMI-1 connected primary
On Debian xrandr says “can’t open display”.

I have failed to notice any different HDMI or display related configurations between Debian & Fedora. Device trees are the same. Booting gives similar messages on both distributions which include “display” string.

Debian’s boot messages complain about a lack of several modules: videobuf2-vmalloc.ko, videobuf2-memops.ko, xr829.ko, uvcvideo.ko. These modules are tried to include in /etc/rc.local file. However it seems that videobuf2 is maybe a bit higher level driver (or rather memory related) and probably not related to this issue (xr829 is wifi stuff).

Debian’s boot log also contains some complaints about missing hdmi related directories (again originating from /etc/rc.local). I tried to find information about these and this directoryname “dispdbg” seems to appear on some Allwinner SoCs. So are these lines just remnants from some other Debian SoC release or are they supposed to be used with VisionFive?
rc.local[305]: hdmi init start
rc.local[305]: /etc/rc.local: line 18: /sys/kernel/debug/dispdbg/name: No such file or directory
rc.local[305]: /etc/rc.local: line 19: /sys/kernel/debug/dispdbg/command: No such file or directory
rc.local[305]: /etc/rc.local: line 20: /sys/kernel/debug/dispdbg/param: No such file or directory
rc.local[305]: /etc/rc.local: line 21: /sys/kernel/debug/dispdbg/start: No such file or directory
rc.local[305]: hdmi init end

I compiled kernel for Debian which had exactly the same configuration as Fedora image ("=M"s converted to "=Y"s) but this didn’t fix the problem.

Raspberry Pi has a program called tvservice to change HDMI configurations. I have failed to find anything similar from VisionFive’s OSs.

1 Like

Which version of the kernel are you using? Is it the same as fedora?

Debian image has 5.17.0-rc5-starfive-rc5 kernel
(I have also tried a kernel updated to 5.18-rc1 by merging with the mainline tree)
Fedora image that I’ve used has 5.15.10+ kernel

Did you use the debian compiled by Houge? ,I just tried it and it shows,also through HDMI-VGA adapter.

Yes, I use that Debian LXDE image. If you got it working with HDMI-VGA, then this issue is getting mysterious… In any case, if there is any way to configure HDMI that I could try, it might help.

The drivers (other than WiFi’s) are for V4L2. Did you plug a USB camera maybe? Not that this has anything to do with the VGA issue.

As for the rc.local errors, they probably mean that debugfs is not mounted (or not enabled in the kernel). I don’t know why your /etc/rc.local contains those commands though. Normally, Debian’s just executes the content of /etc/boot.d/, which should be empty.

I don’t have any other peripherals.

I actually realized that “out of frequency” message seen on my display may be relevant here: maybe the refresh rate (display’s frequency) should be adjusted somehow from Linux. I haven’t yet found out how to do this when xrandr doesn’t find the display at all and also probably X11 isn’t relevant in this case (since the display doesn’t work even on the boot).

If the display server is not running, you can set the mode directly with modetest, e.g.:
modetest -M starfive -D 0 -a -s 34@32:1920x1080 -P 31@32:1920x1080@RG16 -Fsmpte

modetest gives this error message: “failed to set gamma: Permission denied”. So far I’ve failed to track down what’s wrong there (I do it as root of course).

There is probably something in Fedora image that makes it to adjust itself to different screen refresh rates better than Debian but haven’t found out what it is.