No boot from eMMC (Release Image 202302)

I received the eMMC from allnet and using an eMMC to micro sd adapter I flashed the emmc image from another PC and put the eMMC on the board I moved the jumpers to boot from emmc and it won’t start. Only red led on
, no green led blink.

I checked and the partitions were created on the eMMC, I did integrity test on the eMMC and there are no problems.

Does booting from eMMC work for you, if so how did you do it? I’d like to know if I’m doing something wrong.

Power issue, maybe ? What make and model is your power supply ?

5V 6A no issue with SD card and also installed emmc on the board all the time, now i want to try only with the emmc.

1 Like

30W, sounds like power is not the issue then.

The board sees your emmc as an SD card, so set the jumpers to SD

I haven’t tried leaving the dip switches on the SD position without the SD on the board and trying to boot from eMMC.

I assumed that it was necessary to place the dip switches on eMMC to boot from eMMC

next week when i get back to the office i want to try it

Setting the dips switches to eMMC to boot from eMMC is correct from release image 202302, only before that you always had to set it to QSPI flash.

Described here: VisionFive 2 Debian Wiki - 202302 Release

Enchancement and bug fixes

    SD and eMMC boot is now supported. 2 images are provided, 
    one for SD/SPI boot, and one for eMMC boot.

Has anyone done a fresh install on emmc with the new release 202302?

Yes I did, but with mixed success.

And the posts that follow.


i tried again, but i still can’t boot from eMMC.

I flashed the eMMC image again on the eMMC with the eMMC microSD adapter and I checked the correctness of the copied data, there are no errors, I confirm the integrity of the partitions.

the first time I tried with Rufus and this time with Balenaetcher without any problems.

if i try to place the dip switches on eMMC it doesn’t boot, just solid red light. unfortunately still my usb serial adapter hasn’t arrived so I can’t provide further information.

I’m waiting for someone here in the forum to find out if he managed to boot from eMMC and understand if I’m doing something wrong


Hi Mattia, I have some thoughts about this, but I have zero experience with eMMC for this board, so I may be stating the obvious.

  1. I found with this board that booting this board takes a lot more time than other ARM SBCs. I was having problems with my board not booting until … I started it booting and took a “bathroom break”. When I came back it had booted. In follow-up investigation I discovered it takes 15 seconds from when power is applied until the Green-LED starts blinking. 15 seconds sounds like a short amount of time, but the Raspberry Pi 4B board takes only a few seconds to show some boot activity.

  2. Verify that your image can boot from a microSD card, If that works, flash that same image to the eMMC card in the microSD adapter, and insert the adapter (with eMMC) into the microSD slot and verify it also boots. Yes, the microSD slot is slower than the eMMC port on the board, but this is just a test.

Please update us with your results.
Hope this helps … Chuck


depending on the Img you use will depend on if you need to set the switches or not.
Most new images you will not need to change the switches as they use the opensbi/u-boot in the spinor and use the extlinux boot loader. and there for the switches dont have to be set for the use. The only images you have to change the switches for is if they use u-boot in the img. which really they should not. So in closing leave the switches as normal mmc boot attach the emmc and it should boot fine

Thanks for your advice, I hadn’t thought of trying eMMC with the adapter and image for SD. I hope to find the time to do it soon. so I can finally verify the correct functioning of the eMMC, however I see the partitions and it is recognized by the system.

I hope to receive a usb serial adapter soon to be able to see what happens during the eMMC boot phase

in the last image released the 2302, it is clearly specified that the dip switches must be used in the two options, i.e. dip switch setting for SD if we use micro SD and eMMC setting if we use eMMC.

the previous version the 69 instead required to leave the dip switches 1 1 UART mode.

in fact with the 2302 SD image and the dip switches for SD it boots correctly, if I leave the dip switches, despite having updated u-boot and spi to the current version it doesn’t boot.

i think it is correct to implement the firmware on the boot media to allow upgrade directly via apt and not the flashcp method.

That’s how I understand, if I’m wrong then correct me. with dip switch 1 1 UART does not boot from eMMC

Hi Mattia, If you have a raspberry pi (or similar SBC) you can use the UART (Tx/Rx) directly instead of a USB serial adapter. Run a terminal-emulation program (for example mincom, putty …) on the SBC.
I Hope this helps. Chuck

1 Like

1,VF2 SBC has no EMMC IC, * boot from emmc requires an EMMC module。
VisionFive 2 Debian starfive-jh7110-202302-eMMC-minimal-desktop has been released, please download:
3,Use dd if=xxx.img of=/dev/mmcblk0 bs=4096 brush EMMC

thanks zheng, i tried from the system booted from micro sd with dd command to flash the emmc and it didn’t give me errors after executing the command but the situation is the same it won’t boot.

I attach photos of the dip switches in the emmc position and of the inserted emmc which is recognized by the system correctly. I also did integrity tests and never had any errors in the tests. I’m looking forward to other suggestions at this point. unfortunately I can’t read via serial, because I haven’t received the usb serial adapter yet.

grazie a tutti per il vostro prezioso supporto

here are the partitions present, command launched from boot via micro sd correctly working, you see the emmc and its partitions


please download sdcard.img:;
boot via microsd, upload sdcard.img to /root directory;
dd if=sdcard.img of=/dev/mmcblk0 bs=4096 writes the EMMC card;
boot EMMC;