List of updated Linux distributions?

It’s been a long time since I’ve seen the post relating to the updates of the various Linux distributions that support the visionfive2 board.

I recently tried running Ubuntu on paper but I couldn’t boot. Unfortunately I didn’t have time to investigate with the serial port.

It occurs to me that the vendor’s u-boot/spl does not allow running other Linux provisions without loading new U-boot/spl specific to each distribution.

2 Likes

Last official release was in may and other distros got updated images around that date too…so it’s not long ago.

1 Like

Don’t know if I get you correct, but from my point of view we’re booting gentoo with the standard uboot as an example.

2 Likes

Most distributions do…Irradium e.g. does use it’s own u-boot/spl versions. Didn’t try that one from NVME so far, only SD and it works after resetting the environment.

Thanks everyone for your replies. Probably to use other distros I would have to remove my nvme ssd containing the latest official debian release from our strafive team. I would like to test other distros on an SD or EMMC card while maintaining my nvme ssd and not having to delete the nvme ssd or having to disassemble the case to remove the ssd disk.

Because nvme starts with boot switches 0.0 and I was unable to start other distros on micro sd. My interest is relative because I do everything with the official Debian release.

Some time ago I had already complained about the changes to uboot and spl relating to the boot sequence, I would like to be able to choose the boot device despite having emmc nvme or micro sd on board with various distros present and being able to choose which one to use at each reboot , but I recognize that this is an uncommon situation.

1 Like

There is no problem at all doing that. Just set the dip switches to SD boot and (for most distros) you’re good to go. For some other distros it might be necessary to reset the u-boot environment on first boot. But that’s it basically.

I will do some tests because honestly, a long time ago I tried with armbian on micro sd and the only way to boot was to put the switches on 0,0.

If I remember correctly the reason was that the distro did not include uboot and spl and therefore the only way was to use uboot and spl present on the board forcing the boot with the switches at 0,0.

Even if I am very happy with the official debian release of the riscv team when I have some free time I will do other tests.

Thanks for your reply.