First steps with VisionFive2

So I got my board last week and have already put it through some paces getting its QSPI first wrong, and then using the recovery procedure with xmodem. I then got it all setup. Only I wanted a kernel module that wasn’t setup in the sdk delivered one. So I used the sdk to cross one with it enabled as module. That worked well. My edimax worked just fine.
So the I wanted my 8812AU driver wifi also to work (it’s 5G) and so its driver is out of tree. Here. I ran into some troubles. It would not happily cross. So I built it on the board, but now the board wanted the work directory. etc. Eventually I wound up just transferring the linux source clone I had to it and building the kernel there. But now it was uame -r 5.15.0 and my crossed one 5.15.0+. I finally cheated and edited utsrelease.h in include/generated. Then my insmod would work. That was the other thing I had to do was make links for insmod, modprobe and rmmod to /bin/kmod.

So, is there an easier way to build out of tree kernel modules? I notice that buildroot has the packages to build this module, but because it does not build the kernel, it won’t build them. Can buildroot build the kernel (one can set up either a remote git tree or even a directory that points to the kernel sources in buildroot)?

Finally when I do apt-get update I get errors on signature validations. Is there anyway to clean that up?

Thanks, having fun with the board. Looking forward to playing with i2c and spi next weekend with the GPIO pins.

1 Like

Easiest is to build the full kernel, either from 5.15 or 6.1 official starfive trees, or from cwt’s (see else in forum, including Arch thread).

And then build modules against your kernel.

I had built it both via cross (that was the one I installed) and via local on the board (this was the one I ultimately wound up compiling my driver against), but the uname -r of those two versions didn’t match (even though the linux source had been picked up and copied to the board.)
Anyway, my wireless card is working fine. Comes back after reboots and everything.
I’m happy with 5.15 for now.