Bootloader recovery issue

One of the cards I have won’t boot so I thought I should flash the bootloeader reovery over UART. I set the dip switches so I get the CCCCC on the serial port as per the instructions.

Then I do not know how to upload the recovery image I downloaded from the github release page. I use sx but it waits Give your local XMODEM receive command now.

Next I tried the ./jh7100-recover tool from GitHub - xypron/JH71xx-tools: Bootloader recovery and updater tool for StarFive JH71x0 SoCs. but was not able to get it to work. It’s stuck at: Waiting for bootloader mode on /dev/ttyUSB0...

Help would be appreciated.

1 Like

Update: I managed to upload the file using xmodem/minicom, but got CRC Error, Try again

I believe the transfer was successful, even if you got CRC Error, Try again.

See this discussion:

Thus, the error you’re getting is not an XMODEM error. The transfer really completed.

It just failed the CRC check that is implemented after that, because you’ve uploaded an incompatible image. I assume you used a (renamed) JH7100 image, rather than the JH7110 one.

Should you have used the JH7110 image and it failed, try the one from the release dated as my posts in that thread. That one definitely does work. If it’s the case old one works and current doesn’t, it would mean that the current one is broken. That’d be worth reporting if so.

As an alternative altogether, you can boot with the boot switches in sd position, then use u-boot to do the flashing. I cover how here:

Thanks, However, after reading the instructions, I do not think it will work as the current bootloader does not work. Booting from SD-card (with or without card in) I only get the following output on the serial port:

dwmci_s: Response Timeout.
BOOT fail,Error is 0xffffffff

Try the XMODEM based recovery on the other board.

If the other board works, there’s high chances there’s simply something wrong with the board where it doesn’t. (e.g. bad RAM)

Thanks! I am probably doing something strange with the recovery. I cannot get that to work for the board that boots correctly either.

1 Like

Finally I was able to flash new bootloader booting from QSPI



Hi ! Been following your journey, seems it got quite complicated.
Could you maybe do a concise writeup on how you finally got the bootloader flashed ?
Might help someone at some time. :slight_smile: Thanks, K

I spent half of my weekend trying serial port recovery method, but uploading recovery image by minicom or tera term not worked for me. Thankfully, recovery by SD card worked.

1 Like