A unified reply to a question about the display of debian69

yeah, weird. could you please try to boot up with sdimage.img and input modetest -M starfive -D 0 -a -s 116@31:1920x1080 -P 39@31:1920x1080@YUYV -Ftiles or stop the lightdm service in debian and implement above command? thanks.

I get exactly the same bootlog as Tommythorn. Used a native 1920x1080 monitor but without any result. I will try your suggestion, but the sdimage.img is working fine, but is very empty.

I entered this command in the security mode of the 69 image and a colourful screen appeared on the HDMI monitor with diagonal coloured bars.

I see that there is a new 2.6.0 version. Is there a *.img available?

My guess would be that it will be released when ready sometime before the Lunar New Year holiday (22nd January to 5th February 2023).

¿Is it possible to force to other resolution?. Btw, 1280x800 or 1680x1050.
I tried through cvt and xrandr to add both modes with no result.
If this is a controller limitation, please tell me.
Thanks in avance.

The supported resolutions that you can find them by entering “modetest -M starfive -c” but only up to 1920x1080.

1 Like

lightdm --test-mode --debug gave an error and in:
root@starfive:~# cat /var/log/lightdm/seat0-greeter.log

** (process:4006): WARNING **: 13:21:18.890: Failed to open CK session: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.ConsoleKit was not provided by any .service files
** Message: 13:21:19.516: Starting lightdm-gtk-greeter 2.0.8 (Aug 17 2021, 15:44:22)
** Message: 13:21:19.517: [Configuration] Reading file: /usr/share/lightdm/lightdm-gtk-greeter.conf.d/01_debian.conf
** Message: 13:21:19.517: [Configuration] Reading file: /etc/lightdm/lightdm-gtk-greeter.conf
Failed to launch bus: Failed to connect to session busExcess arguments.

[+2.63s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+2.63s] DEBUG: Starting Light Display Manager 1.26.0, UID=0 PID=4065
[+2.63s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
[+2.63s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/01_debian.conf
[+2.63s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
[+2.63s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
[+2.63s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+2.63s] DEBUG: Registered seat module local
[+2.63s] DEBUG: Registered seat module xremote
[+2.63s] DEBUG: Registered seat module unity
[+2.63s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+2.65s] DEBUG: _g_io_module_get_default: Found default implementation gvfs (GDaemonVfs) for ?gio-vfs?
[+2.65s] DEBUG: Monitoring logind for seats
[+2.65s] DEBUG: New seat added from logind: seat0
[+2.65s] DEBUG: Seat seat0: Loading properties from config section Seat:*
[+2.65s] DEBUG: Seat seat0 has property CanMultiSession=no
[+2.65s] DEBUG: Seat seat0: Starting
[+2.65s] DEBUG: Seat seat0: Creating greeter session
[+2.65s] DEBUG: Seat seat0: Creating display server of type x
[+2.66s] DEBUG: Using VT 7
[+2.66s] DEBUG: Seat seat0: Starting local X display on VT 7
[+2.66s] DEBUG: XServer 0: Logging to /var/log/lightdm/x-0.log
[+2.66s] DEBUG: XServer 0: Writing X server authority to /var/run/lightdm/root/:0
[+2.66s] DEBUG: XServer 0: Launching X Server
[+2.66s] DEBUG: Launching process 4070: /usr/bin/X :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
[+2.66s] DEBUG: XServer 0: Waiting for ready signal from X server :0
[+2.66s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+2.66s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+2.67s] WARNING: Error getting user list from org.freedesktop.Accounts: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Accounts was not provided by any .service files
[+2.67s] DEBUG: Loading user config from /etc/lightdm/users.conf
[+2.67s] DEBUG: User user added
[+4.29s] DEBUG: Got signal 10 from process 4070
[+4.29s] DEBUG: XServer 0: Got signal from X server :0
[+4.29s] DEBUG: XServer 0: Connecting to XServer :0
[+4.33s] DEBUG: Seat seat0: Display server ready, starting session authentication
[+4.33s] DEBUG: Session pid=4076: Started with service ‘lightdm-greeter’, username ‘lightdm’

** (process:4076): WARNING **: 13:41:37.703: Error getting user list from org.freedesktop.Accounts: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Accounts was not provided by any .service files
[+4.37s] DEBUG: Session pid=4076: Authentication complete with return value 0: Success
[+4.37s] DEBUG: Seat seat0: Session authenticated, running command
[+4.37s] DEBUG: Session pid=4076: Running command /usr/sbin/lightdm-gtk-greeter
[+4.37s] DEBUG: Creating shared data directory /var/lib/lightdm/data/lightdm
[+4.37s] DEBUG: Session pid=4076: Logging to /var/log/lightdm/seat0-greeter.log
[+4.40s] DEBUG: Activating VT 7
[+5.17s] DEBUG: Greeter connected version=1.26.0 api=1 resettable=false
[+5.57s] DEBUG: Greeter closed communication channel
[+5.57s] DEBUG: Session pid=4076: Exited with return value 1
[+5.57s] DEBUG: Seat seat0: Session stopped
[+5.57s] DEBUG: Seat seat0: Stopping; failed to start a greeter
[+5.57s] DEBUG: Seat seat0: Stopping
[+5.57s] DEBUG: Seat seat0: Stopping display server
[+5.57s] DEBUG: Sending signal 15 to process 4070
[+5.93s] DEBUG: Process 4070 exited with return value 0
[+5.93s] DEBUG: XServer 0: X server stopped
[+5.93s] DEBUG: Releasing VT 7
[+5.93s] DEBUG: XServer 0: Removing X server authority /var/run/lightdm/root/:0
[+5.93s] DEBUG: Seat seat0: Display server stopped
[+5.93s] DEBUG: Seat seat0: Stopped
[+5.93s] DEBUG: Required seat has stopped
[+5.93s] DEBUG: Stopping display manager
[+5.93s] DEBUG: Display manager stopped
[+5.93s] DEBUG: Stopping daemon
[+5.93s] DEBUG: Exiting with return value 1

Hi Michael,

In case this is still relevant, I dropped the linked sdimage.img (containting a buildroot image) on an SDcard, attached my VisionFive 2 to the Asus Aurus FI27Q and powered it up to a black screen as before. Found the IP address and executed the requested command. Note after the output below the command hangs (waited 15 min):

# ps axf|grep lightdm
  657 root     grep lightdm
# modetest -M starfive -D 0 -a -s 116@31:1920x1080 -P 39@31:1920x1080@YUYV -Ftiles
setting mode 1920x1080-120.00Hz on connectors 116, crtc 31
testing 1920x1080@YUYV on plane 39, crtc 31

oh, sorry, I forgot the default framerate of your monitor is 120fps. please change the command as below:

modetest -M starfive -D 0 -a -s 116@31:1920x1080-60.00 -P 39@31:1920x1080@YUYV -Ftiles

1 Like

Progress! Does that mean there is something magic I can put in /etc/lightdm/lightdm.conf to get this to work?
EDIT: FWIW, this was from the debian-69 images with no lightdm running.
EDIT2: curiously it doesn’t work now, even after a reboot. I get “failed to find mode “1920x1080-60.00Hz” for connector 116”

1 Like

@tommythorn sorry for late response.
Generally, xrandr couldn’t be modified default resolution and you need add a auto script like this

root@starfive:/etc/xdg/autostart# cat default_pixel.desktop
[Desktop Entry]

and the pixel.sh contains how to use xrandr to indicate a specific resolution like this:

root@starfive:/etc/xdg/autostart# cat /root/pixel.sh
xrandr --output HDMI-1 --mode 1280x720 -r 50

reboot and hope that works


have the same Issue.
I dont even get any Output.
Tried all steps mentioned here.

Here is my Post:

Thanks for the heads up! Worked like a charm! Dell U3219Q here …

1 Like

I was following the steps here but didn’t make any progress.

modetest -M starfive -D 0 -a -s 116@31:1920x1080-60.00 -P 39@31:1920x1080@YUYV -Ftiles

Works for me…It displays the pattern that Tommy also posted.

However setting lightdm.conf does not lead anywhere after a reboot.
If I try running sudo xrandr -s 1920x1080 I just get the Can't open display message.

Any further advice on debugging this?

Can you try to flash a latest version of debian VisionFive 2 Debian Image 202303 Released(latest) and set the SD boot mode to start up?

Thanks Michael that works perfectly!
The colors were a bit weird on initial boot up but after change the resolution that seems solved.
Oh and I needed to adjust the dip switches as you mentioned in the release post.

I see you added support for 4k resolution now.
Not sure how “hardcoded” that is.
The 1440p monitor I’m using seems to only go up to 1080p with the VisionFive 2.

Ok the pink tint comes back after some minutes and can seemingly only be removed by setting the screen resolution again.
Is this a common issue?

you can run the script under /opt and reboot.